summaryrefslogtreecommitdiff
path: root/libeggsmclient/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libeggsmclient/Makefile.am')
-rw-r--r--libeggsmclient/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/libeggsmclient/Makefile.am b/libeggsmclient/Makefile.am
new file mode 100644
index 00000000..62cde707
--- /dev/null
+++ b/libeggsmclient/Makefile.am
@@ -0,0 +1,18 @@
+INCLUDES = -DGTK_DISABLE_DEPRECATED \
+ -DGDK_DISABLE_DEPRECATED \
+ -DG_DISABLE_DEPRECATED
+
+noinst_LTLIBRARIES = libeggsmclient.la
+
+libeggsmclient_la_LIBADD = $(LIBEGGSMCLIENT_LIBS) \
+ -lSM -lICE
+libeggsmclient_la_CFLAGS = $(LIBEGGSMCLIENT_CFLAGS) \
+ -DEGG_SM_CLIENT_BACKEND_XSMP \
+ -DG_LOG_DOMAIN=\""EggSMClient"\" \
+ $(WARN_CFLAGS)
+libeggsmclient_la_SOURCES = eggdesktopfile.h \
+ eggdesktopfile.c \
+ eggsmclient.h \
+ eggsmclient.c \
+ eggsmclient-private.h \
+ eggsmclient-xsmp.c