summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorinfirit <[email protected]>2014-05-19 15:45:02 +0200
committerinfirit <[email protected]>2014-05-19 18:37:37 +0200
commitcc28312a3f00a21d7fdf982ae9abce782878d906 (patch)
treef60c43c8d3f38edf57cff8745f05adaefa34990f /configure.ac
parent51291bf1b29004ea4703845fc127cc1a4468b092 (diff)
downloadpluma-cc28312a3f00a21d7fdf982ae9abce782878d906.tar.bz2
pluma-cc28312a3f00a21d7fdf982ae9abce782878d906.tar.xz
Drop support for gtk+ < 2.24
* Bump required gtk+2 version * Remove pluma-spinner * Remove pluma-message-are
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 1 insertions, 24 deletions
diff --git a/configure.ac b/configure.ac
index 82519b6d..d7bfd702 100644
--- a/configure.ac
+++ b/configure.ac
@@ -280,7 +280,7 @@ AC_MSG_RESULT([$with_gtk])
case "$with_gtk" in
2.0) GTK_API_VERSION=2.0
- GTK_REQUIRED=2.20.0
+ GTK_REQUIRED=2.24.0
;;
3.0) GTK_API_VERSION=3.0
GTK_REQUIRED=3.0.0
@@ -315,29 +315,6 @@ PLUMA_LIBS="$PLUMA_LIBS $X11_LIBS"
AC_SUBST(PLUMA_CFLAGS)
AC_SUBST(PLUMA_LIBS)
-dnl FIXME: Remove this when removing pluma-message-area
-
-if $PKG_CONFIG --atleast-version 2.17.1 gtk+-$GTK_API_VERSION; then
- gtkatleast=
-else
- gtkatleast=no
-fi
-
-AM_CONDITIONAL(BUILD_MESSAGE_AREA, test "$gtkatleast" = "no")
-
-dnl FIXME: Remove this when removing pluma-spinner
-
-if $PKG_CONFIG --atleast-version 2.19.0 gtk+-$GTK_API_VERSION; then
- gtkatleast=
-else
- gtkatleast=no
-fi
-
-AM_CONDITIONAL(BUILD_SPINNER, test "$gtkatleast" = "no")
-if test "$gtkatleast" = "no"; then
- AC_DEFINE([BUILD_SPINNER],[1],[Whether to use PlumaSpinner instead of GtkSpinner])
-fi
-
if test "$os_osx" = "no" &&
test "$os_win32" = "no"; then
PKG_CHECK_MODULES(EGG_SMCLIENT, [