summaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorWu Xiaotian <[email protected]>2019-11-09 15:33:24 +0800
committerraveit65 <[email protected]>2019-12-01 11:39:44 +0100
commit93881642e533133ef9f455612611002531e4475e (patch)
treeb25e92a1cd42271762116dd226ddabf7e78ad99d /data/Makefile.am
parent6dd6ad739acc075119cb03f62b0cceacef006345 (diff)
downloadpluma-93881642e533133ef9f455612611002531e4475e.tar.bz2
pluma-93881642e533133ef9f455612611002531e4475e.tar.xz
migrate from intltool to gettext
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 12d8a058..21c26baa 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -1,12 +1,14 @@
desktopdir = $(datadir)/applications
desktop_in_files = pluma.desktop.in
desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
-@INTLTOOL_DESKTOP_RULE@
+$(desktop_DATA): $(desktop_in_files)
+ $(AM_V_GEN) $(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
-@INTLTOOL_XML_RULE@
appdatadir = $(datadir)/metainfo
appdata_in_files = pluma.appdata.xml.in
appdata_DATA = $(appdata_in_files:.xml.in=.xml)
+$(appdata_DATA): $(appdata_in_files)
+ $(AM_V_GEN) GETTEXTDATADIRS=$(top_srcdir) $(MSGFMT) --xml --template $< -d $(top_srcdir)/po -o $@
gsettings_SCHEMAS = org.mate.pluma.gschema.xml
@GSETTINGS_RULES@