summaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorraveit65 <[email protected]>2015-06-16 00:56:55 +0200
committerraveit65 <[email protected]>2015-06-16 00:56:55 +0200
commitb9133a18f88938db0afdd88f4fffc419e6477c09 (patch)
tree9ca92c224599e1ea5259525a4e3ec1a60b2fc37b /data/Makefile.am
parent0f093c69c0c6bfdc7560da1bb6b516a28665bdac (diff)
downloadpluma-b9133a18f88938db0afdd88f4fffc419e6477c09.tar.bz2
pluma-b9133a18f88938db0afdd88f4fffc419e6477c09.tar.xz
fixes for gschema translation
taken from: https://github.com/mate-desktop/eom/commit/a2055e1 - bumped required intltool version to 0.50.1 - renamed and corrected gschema xml for proper intltool usage - removed obsolete lines from po/POTFILES.skip
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am21
1 files changed, 6 insertions, 15 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 002a9031..110d583a 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -11,13 +11,6 @@ appdata_DATA = $(appdata_in_files:.xml.in=.xml)
gsettings_SCHEMAS = org.mate.pluma.gschema.xml
@GSETTINGS_RULES@
-%.gschema.xml.in: %.gschema.xml.in.in Makefile
- $(AM_V_GEN) $(SED) \
- -e 's^\@GETTEXT_PACKAGE\@^$(GETTEXT_PACKAGE)^g' \
- -e 's^\@ACTIVE_PLUGINS\@^$(ACTIVE_PLUGINS)^g' \
- -e 's^\@TOOLBAR_STYLE\@^$(TOOLBAR_STYLE)^g' \
- < $< > $@
-
convertdir = $(datadir)/MateConf/gsettings
convert_DATA = pluma.convert
@@ -29,21 +22,19 @@ pkgconfig_DATA = pluma.pc
bugreportdir = $(libexecdir)/pluma
bugreport_SCRIPTS = pluma-bugreport.sh
-EXTRA_DIST = \
- $(appdata_in_files) \
- $(desktop_in_files) \
- $(gsettings_SCHEMAS).in.in \
- $(convert_DATA) \
+EXTRA_DIST = \
+ $(appdata_in_files) \
+ $(desktop_in_files) \
+ $(convert_DATA) \
$(man_MANS) \
pluma.pc.in \
pluma-bugreport.sh.in
CLEANFILES = \
$(desktop_DATA) \
- $(gsettings_SCHEMAS_in) \
- $(gsettings_SCHEMAS) \
+ $(gsettings_SCHEMAS) \
$(pkgconfig_DATA) \
- pluma.appdata.xml
+ $(appdata_DATA)