summaryrefslogtreecommitdiff
path: root/gedit/osx/Makefile.am
diff options
context:
space:
mode:
authorPerberos <[email protected]>2011-11-07 16:46:58 -0300
committerPerberos <[email protected]>2011-11-07 16:46:58 -0300
commit528c1e5ff51e213936e800fc5a9a25da99c0bdf2 (patch)
tree77f8aa456b09367ba81f04d4562fc935f898a951 /gedit/osx/Makefile.am
downloadpluma-528c1e5ff51e213936e800fc5a9a25da99c0bdf2.tar.bz2
pluma-528c1e5ff51e213936e800fc5a9a25da99c0bdf2.tar.xz
initial
Diffstat (limited to 'gedit/osx/Makefile.am')
-rwxr-xr-xgedit/osx/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/gedit/osx/Makefile.am b/gedit/osx/Makefile.am
new file mode 100755
index 00000000..4d734169
--- /dev/null
+++ b/gedit/osx/Makefile.am
@@ -0,0 +1,23 @@
+INCLUDES = \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ -I$(top_srcdir)/gedit \
+ -I$(top_builddir)/gedit \
+ $(GEDIT_CFLAGS) \
+ $(IGE_MAC_CFLAGS) \
+ $(WARN_CFLAGS) \
+ $(DISABLE_DEPRECATED_CFLAGS)
+
+noinst_LTLIBRARIES = libosx.la
+
+libosx_la_LDFLAGS = -framework Carbon -framework ApplicationServices -framework Cocoa
+libosx_la_LIBADD = -lobjc
+libosx_la_CFLAGS = -xobjective-c
+
+libosx_la_SOURCES = \
+ gedit-osx.c \
+ gedit-osx.h \
+ gedit-osx-delegate.m \
+ gedit-osx-delegate.h
+
+-include $(top_srcdir)/git.mk