summaryrefslogtreecommitdiff
path: root/plugins/checkupdate/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2013-01-24 21:05:32 +0100
committerStefano Karapetsas <[email protected]>2013-01-24 21:05:32 +0100
commit698c1a83b5f2d566cf8a6500f49158f98c1efacf (patch)
tree9ed67a87562341719d8ad33c191e072b412af4bc /plugins/checkupdate/Makefile.am
parent4bcb3b6f8b35aad20674fd88d97378d0612c10f2 (diff)
downloadpluma-698c1a83b5f2d566cf8a6500f49158f98c1efacf.tar.bz2
pluma-698c1a83b5f2d566cf8a6500f49158f98c1efacf.tar.xz
checkupdate: Migrate to GSettings
Diffstat (limited to 'plugins/checkupdate/Makefile.am')
-rw-r--r--plugins/checkupdate/Makefile.am33
1 files changed, 12 insertions, 21 deletions
diff --git a/plugins/checkupdate/Makefile.am b/plugins/checkupdate/Makefile.am
index a49666ca..471f8b04 100644
--- a/plugins/checkupdate/Makefile.am
+++ b/plugins/checkupdate/Makefile.am
@@ -24,26 +24,17 @@ plugin_in_files = checkupdate.pluma-plugin.desktop.in
plugin_DATA = $(plugin_in_files:.pluma-plugin.desktop.in=.pluma-plugin)
-schemasdir = $(MATECONF_SCHEMA_FILE_DIR)
-schemas_in_files = pluma-check-update.schemas.in
-schemas_DATA = $(schemas_in_files:.schemas.in=.schemas)
-@INTLTOOL_SCHEMAS_RULE@
-
-if MATECONF_SCHEMAS_INSTALL
-install-data-local:
- if test -z "$(DESTDIR)" ; then \
- for p in $(schemas_DATA) ; do \
- MATECONF_CONFIG_SOURCE=$(MATECONF_SCHEMA_CONFIG_SOURCE) $(MATECONFTOOL) --makefile-install-rule $(top_builddir)/plugins/checkupdate/$$p ; \
- done \
- fi
-else
-install-data-local:
-endif
-
-EXTRA_DIST = $(plugin_in_files) $(schemas_in_files)
-
-CLEANFILES = $(plugin_DATA) $(schemas_DATA)
-
-DISTCLEANFILES = $(plugin_DATA) $(schemas_DATA)
+@INTLTOOL_XML_NOMERGE_RULE@
+gsettings_SCHEMAS = org.mate.pluma.plugins.checkupdate.gschema.xml
+@GSETTINGS_RULES@
+
+%.gschema.xml.in: %.gschema.xml.in.in Makefile
+ $(AM_V_GEN) $(SED) -e 's^\@GETTEXT_PACKAGE\@^$(GETTEXT_PACKAGE)^g' < $< > $@
+
+EXTRA_DIST = $(plugin_in_files) $(gsettings_SCHEMAS_in_in)
+
+CLEANFILES = $(plugin_DATA) $(gsettings_SCHEMAS_in) $(gsettings_SCHEMAS)
+
+DISTCLEANFILES = $(plugin_DATA) $(gsettings_SCHEMAS_in) $(gsettings_SCHEMAS)
-include $(top_srcdir)/git.mk