summaryrefslogtreecommitdiff
path: root/plugins/filebrowser/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2013-01-24 21:05:58 +0100
committerStefano Karapetsas <[email protected]>2013-01-24 21:05:58 +0100
commit0a745cb559ffbcfad564437b214e649e0476d0f3 (patch)
tree99b384c12a0c413676af0da2238901260759701b /plugins/filebrowser/Makefile.am
parent698c1a83b5f2d566cf8a6500f49158f98c1efacf (diff)
downloadpluma-0a745cb559ffbcfad564437b214e649e0476d0f3.tar.bz2
pluma-0a745cb559ffbcfad564437b214e649e0476d0f3.tar.xz
filebrowser: Migrate to GSettings
Diffstat (limited to 'plugins/filebrowser/Makefile.am')
-rw-r--r--plugins/filebrowser/Makefile.am29
1 files changed, 11 insertions, 18 deletions
diff --git a/plugins/filebrowser/Makefile.am b/plugins/filebrowser/Makefile.am
index 6791255a..cb03c183 100644
--- a/plugins/filebrowser/Makefile.am
+++ b/plugins/filebrowser/Makefile.am
@@ -65,27 +65,18 @@ pluma-file-browser-marshal.c: pluma-file-browser-marshal.list $(GLIB_GENMARSHAL)
plugin_DATA = $(plugin_in_files:.pluma-plugin.desktop.in=.pluma-plugin)
-schemasdir = $(MATECONF_SCHEMA_FILE_DIR)
-schemas_in_files = pluma-file-browser.schemas.in
-schemas_DATA = $(schemas_in_files:.schemas.in=.schemas)
-@INTLTOOL_SCHEMAS_RULE@
-
-if MATECONF_SCHEMAS_INSTALL
-install-data-local:
- if test -z "$(DESTDIR)" ; then \
- for p in $(schemas_DATA) ; do \
- MATECONF_CONFIG_SOURCE=$(MATECONF_SCHEMA_CONFIG_SOURCE) $(MATECONFTOOL) --makefile-install-rule $(top_builddir)/plugins/filebrowser/$$p ; \
- done \
- fi
-else
-install-data-local:
-endif
+@INTLTOOL_XML_NOMERGE_RULE@
+gsettings_SCHEMAS = org.mate.pluma.plugins.filebrowser.gschema.xml
+@GSETTINGS_RULES@
+
+%.gschema.xml.in: %.gschema.xml.in.in Makefile
+ $(AM_V_GEN) $(SED) -e 's^\@GETTEXT_PACKAGE\@^$(GETTEXT_PACKAGE)^g' < $< > $@
EXTRA_DIST = \
$(ui_DATA) \
$(plugin_in_files) \
- $(schemas_in_files) \
+ $(gsettings_SCHEMAS_in_in) \
pluma-file-browser-enum-types.h.template \
pluma-file-browser-enum-types.c.template \
pluma-file-browser-enum-register.c.template \
@@ -93,12 +84,14 @@ EXTRA_DIST = \
CLEANFILES = \
$(plugin_DATA) \
- $(schemas_DATA) \
+ $(gsettings_SCHEMAS_in) \
+ $(gsettings_SCHEMAS) \
$(BUILT_SOURCES)
DISTCLEANFILES = \
$(plugin_DATA) \
- $(schemas_DATA) \
+ $(gsettings_SCHEMAS_in) \
+ $(gsettings_SCHEMAS) \
$(BUILT_SOURCES)
-include $(top_srcdir)/git.mk