summaryrefslogtreecommitdiff
path: root/plugins/filebrowser/Makefile.am
diff options
context:
space:
mode:
authorinfirit <[email protected]>2015-09-08 17:19:30 +0200
committerinfirit <[email protected]>2015-09-08 17:19:30 +0200
commitca8ca6923e74bb307bfe6c99c691399987eda7ed (patch)
tree81443d808378577ab19fe39beda57755788ecd3f /plugins/filebrowser/Makefile.am
parent3d9e640cc4221a43d214951da5cbdc43c4f55662 (diff)
downloadpluma-ca8ca6923e74bb307bfe6c99c691399987eda7ed.tar.bz2
pluma-ca8ca6923e74bb307bfe6c99c691399987eda7ed.tar.xz
Rework gsettings schema building
* Bump intltool required version for gsettings support * Extract strings with intltool directly * Let autoconf generate the xml files
Diffstat (limited to 'plugins/filebrowser/Makefile.am')
-rw-r--r--plugins/filebrowser/Makefile.am9
1 files changed, 3 insertions, 6 deletions
diff --git a/plugins/filebrowser/Makefile.am b/plugins/filebrowser/Makefile.am
index 2124904c..3b494cdf 100644
--- a/plugins/filebrowser/Makefile.am
+++ b/plugins/filebrowser/Makefile.am
@@ -66,17 +66,14 @@ pluma-file-browser-marshal.c: pluma-file-browser-marshal.list $(GLIB_GENMARSHAL)
plugin_DATA = $(plugin_in_files:.pluma-plugin.desktop.in=.pluma-plugin)
@INTLTOOL_XML_NOMERGE_RULE@
-gsettings_SCHEMAS = org.mate.pluma.plugins.filebrowser.gschema.xml
+filebrowser_gschema_in = org.mate.pluma.plugins.filebrowser.gschema.xml.in
+gsettings_SCHEMAS = $(filebrowser_gschema_in:.xml.in=.xml)
@GSETTINGS_RULES@
-%.gschema.xml.in: %.gschema.xml.in.in Makefile
- $(AM_V_GEN) $(SED) -e 's^\@GETTEXT_PACKAGE\@^$(GETTEXT_PACKAGE)^g' < $< > $@
-
-
EXTRA_DIST = \
$(ui_DATA) \
$(plugin_in_files) \
- $(gsettings_SCHEMAS).in.in \
+ $(filebrowser_gschema_in) \
pluma-file-browser-enum-types.h.template \
pluma-file-browser-enum-types.c.template \
pluma-file-browser-enum-register.c.template \