summaryrefslogtreecommitdiff
path: root/plugins/spell/Makefile.am
diff options
context:
space:
mode:
authormbkma <[email protected]>2020-10-04 18:09:56 +0200
committerraveit65 <[email protected]>2020-10-19 10:59:44 +0200
commit0830446ca167e24e3105bb76fcf5aabc13608b54 (patch)
tree22e0154a981ab80e7f2d11702e61fe522b127094 /plugins/spell/Makefile.am
parentae86d50d909e7e20b856107614b255104c8850a6 (diff)
downloadpluma-0830446ca167e24e3105bb76fcf5aabc13608b54.tar.bz2
pluma-0830446ca167e24e3105bb76fcf5aabc13608b54.tar.xz
Remove pluma-marshal.
These days we can use the automatic ffi marshalling. See: - https://developer.gnome.org/gobject/stable/gobject-Signals.html#g-signal-new - http://sourceware.org/libffi/ - https://gitlab.gnome.org/GNOME/gedit/-/commit/373adb7d041b0559953d0ac8cf2213ecc44db956
Diffstat (limited to 'plugins/spell/Makefile.am')
-rw-r--r--plugins/spell/Makefile.am16
1 files changed, 2 insertions, 14 deletions
diff --git a/plugins/spell/Makefile.am b/plugins/spell/Makefile.am
index 79f67c1b..587596c5 100644
--- a/plugins/spell/Makefile.am
+++ b/plugins/spell/Makefile.am
@@ -7,10 +7,6 @@ AM_CPPFLAGS = \
$(ENCHANT_CFLAGS) \
$(WARN_CFLAGS)
-BUILT_SOURCES = \
- pluma-spell-marshal.c \
- pluma-spell-marshal.h
-
plugin_LTLIBRARIES = libspell.la
libspell_la_SOURCES = \
@@ -28,9 +24,9 @@ libspell_la_SOURCES = \
pluma-automatic-spell-checker.h \
pluma-spell-utils.c \
pluma-spell-utils.h \
- $(BUILT_SOURCES)
+ $(BUILT_SOURCES)
-libspell_la_LDFLAGS = $(PLUGIN_LIBTOOL_FLAGS)
+libspell_la_LDFLAGS = $(PLUGIN_LIBTOOL_FLAGS)
libspell_la_LIBADD = $(PLUMA_LIBS) $(ENCHANT_LIBS)
uidir = $(PLUMA_PLUGINS_DATA_DIR)/spell
@@ -38,13 +34,6 @@ ui_files = spell-checker.ui languages-dialog.ui pluma-spell-setup-dialog.ui
include $(top_srcdir)/gla11y.mk
ui_DATA = $(ui_files)
-pluma-spell-marshal.h: pluma-spell-marshal.list $(GLIB_GENMARSHAL)
- $(AM_V_GEN) $(GLIB_GENMARSHAL) $< --header --prefix=pluma_marshal > $@
-
-pluma-spell-marshal.c: pluma-spell-marshal.list $(GLIB_GENMARSHAL)
- $(AM_V_GEN) echo "#include \"pluma-spell-marshal.h\"" > $@ && \
- $(GLIB_GENMARSHAL) $< --body --prefix=pluma_marshal >> $@
-
plugin_in_files = spell.plugin.desktop.in
plugin_DATA = $(plugin_in_files:.plugin.desktop.in=.plugin)
@@ -59,7 +48,6 @@ gsettings_SCHEMAS = $(spell_gschema_in:.xml.in=.xml)
EXTRA_DIST = \
$(ui_DATA) \
$(plugin_in_files) \
- pluma-spell-marshal.list \
$(spell_gschema_in) \
ui-a11y.suppr