summaryrefslogtreecommitdiff
path: root/plugins/taglist/Makefile.am
diff options
context:
space:
mode:
authorPerberos <[email protected]>2011-11-07 16:46:58 -0300
committerPerberos <[email protected]>2011-11-07 16:46:58 -0300
commit528c1e5ff51e213936e800fc5a9a25da99c0bdf2 (patch)
tree77f8aa456b09367ba81f04d4562fc935f898a951 /plugins/taglist/Makefile.am
downloadpluma-528c1e5ff51e213936e800fc5a9a25da99c0bdf2.tar.bz2
pluma-528c1e5ff51e213936e800fc5a9a25da99c0bdf2.tar.xz
initial
Diffstat (limited to 'plugins/taglist/Makefile.am')
-rwxr-xr-xplugins/taglist/Makefile.am60
1 files changed, 60 insertions, 0 deletions
diff --git a/plugins/taglist/Makefile.am b/plugins/taglist/Makefile.am
new file mode 100755
index 00000000..b04f4584
--- /dev/null
+++ b/plugins/taglist/Makefile.am
@@ -0,0 +1,60 @@
+# Tag list plugin
+plugindir = $(GEDIT_PLUGINS_LIBS_DIR)
+
+taglistdir = $(GEDIT_PLUGINS_DATA_DIR)/taglist
+
+taglist_in_files = \
+ HTML.tags.xml.in \
+ Latex.tags.xml.in \
+ XSLT.tags.xml.in \
+ XUL.tags.xml.in
+
+taglist_DATA = $(taglist_in_files:.tags.xml.in=.tags.gz)
+
+INCLUDES = \
+ -I$(top_srcdir) \
+ $(GEDIT_CFLAGS) \
+ $(WARN_CFLAGS) \
+ $(DISABLE_DEPRECATED_CFLAGS)
+
+plugin_LTLIBRARIES = libtaglist.la
+
+libtaglist_la_SOURCES = \
+ gedit-taglist-plugin-parser.c \
+ gedit-taglist-plugin-parser.h \
+ gedit-taglist-plugin-panel.c \
+ gedit-taglist-plugin-panel.h \
+ gedit-taglist-plugin.c \
+ gedit-taglist-plugin.h
+
+libtaglist_la_LDFLAGS = $(PLUGIN_LIBTOOL_FLAGS)
+libtaglist_la_LIBADD = $(GEDIT_LIBS)
+
+plugin_in_files = taglist.gedit-plugin.desktop.in
+
+%.gedit-plugin: %.gedit-plugin.desktop.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*po)
+ $(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
+
+GZIP_ENV = -9
+
+%.tags.gz: %.tags.xml.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*.po)
+ LC_ALL=C $(INTLTOOL_MERGE) $(top_srcdir)/po $< $(@:.gz=) -x -u -c $(top_builddir)/po/.intltool-merge-cache
+ GZIP=$(GZIP_ENV) gzip -f $(@:.gz=)
+
+plugin_DATA = $(plugin_in_files:.gedit-plugin.desktop.in=.gedit-plugin)
+
+EXTRA_DIST = \
+ $(taglist_in_files) $(taglist_DATA) \
+ $(plugin_in_files) $(plugin_DATA)
+
+CLEANFILES = \
+ $(taglist_DATA) \
+ $(plugin_DATA)
+DISTCLEANFILES = \
+ $(taglist_DATA) \
+ $(plugin_DATA)
+
+
+
+
+-include $(top_srcdir)/git.mk