summaryrefslogtreecommitdiff
path: root/plugins/taglist/Makefile.am
diff options
context:
space:
mode:
authormonsta <[email protected]>2016-12-05 17:36:57 +0300
committermonsta <[email protected]>2016-12-05 17:36:57 +0300
commite1fbe56adf49a5f4d3a3bb493933d9ae5a5c081f (patch)
treedb922a4aa29bfabf5572e44e334e23c19af3641c /plugins/taglist/Makefile.am
parentce25be232024458af2a28f4cf145d8cd22f2db29 (diff)
downloadpluma-e1fbe56adf49a5f4d3a3bb493933d9ae5a5c081f.tar.bz2
pluma-e1fbe56adf49a5f4d3a3bb493933d9ae5a5c081f.tar.xz
plugins: make them actually recognized and loaded by Pluma
- use *.plugin extension instead of *.pluma-plugin - use "Plugin" section name instead of "Pluma Plugin" mostly adapted from: https://git.gnome.org/browse/gedit/commit/?id=1d56b827f14096891bb03dbd5e8211fdad1331ad https://git.gnome.org/browse/gedit/commit/?id=7c22769d73f756b9d1388febd147c9d267ed54cb
Diffstat (limited to 'plugins/taglist/Makefile.am')
-rw-r--r--plugins/taglist/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/plugins/taglist/Makefile.am b/plugins/taglist/Makefile.am
index 2b85c58a..044fae3f 100644
--- a/plugins/taglist/Makefile.am
+++ b/plugins/taglist/Makefile.am
@@ -30,9 +30,9 @@ libtaglist_la_SOURCES = \
libtaglist_la_LDFLAGS = $(PLUGIN_LIBTOOL_FLAGS)
libtaglist_la_LIBADD = $(PLUMA_LIBS)
-plugin_in_files = taglist.pluma-plugin.desktop.in
+plugin_in_files = taglist.plugin.desktop.in
-%.pluma-plugin: %.pluma-plugin.desktop.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*po)
+%.plugin: %.plugin.desktop.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*po)
$(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
GZIP_ENV = -9
@@ -41,7 +41,7 @@ GZIP_ENV = -9
LC_ALL=C $(INTLTOOL_MERGE) $(top_srcdir)/po $< $(@:.gz=) -x -u -c $(top_builddir)/po/.intltool-merge-cache
GZIP=$(GZIP_ENV) gzip -n -f $(@:.gz=)
-plugin_DATA = $(plugin_in_files:.pluma-plugin.desktop.in=.pluma-plugin)
+plugin_DATA = $(plugin_in_files:.plugin.desktop.in=.plugin)
EXTRA_DIST = \
$(taglist_in_files) $(taglist_DATA) \