summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 5 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index 0f7ddc15..46c9106d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -10,22 +10,18 @@ endif
distuninstallcheck_listfiles = find . -type f -print | grep -v scrollkeeper
EXTRA_DIST = \
- BUGS \
- ChangeLog-20011116 \
- ChangeLog-20051212 \
- ChangeLog-20090418 \
+ ChangeLog \
HACKING \
- MAINTAINERS \
- pluma.doap \
+ NEWS \
+ NEWS.GNOME \
+ README \
xmldocs.make \
omf.make \
- mate-doc-utils.make \
intltool-extract.in \
intltool-merge.in \
intltool-update.in
DISTCLEANFILES = \
- mate-doc-utils.make \
intltool-extract \
intltool-merge \
intltool-update
@@ -49,7 +45,6 @@ MAINTAINERCLEANFILES = \
omf.make \
py-compile \
xmldocs.make \
- m4/mate-doc-utils.m4 \
m4/gtk-doc.m4 \
m4/intltool.m4 \
m4/libtool.m4 \
@@ -61,14 +56,12 @@ MAINTAINERCLEANFILES = \
DISTCHECK_CONFIGURE_FLAGS = --disable-scrollkeeper --enable-gtk-doc
-CHANGELOG_START = PLUMA_2_26_1
-
dist-hook:
@if test -d "$(srcdir)/.git"; \
then \
echo Creating ChangeLog && \
(GIT_DIR=$(top_srcdir)/.git \
- ./missing --run git log $(CHANGELOG_START)^^.. --stat -M -C --name-status --date=short --no-color) | \
+ ./missing --run git log --stat -M -C --name-status --date=short --no-color) | \
fmt --split-only > ChangeLog.tmp \
&& mv -f ChangeLog.tmp $(top_distdir)/ChangeLog \
|| ( rm -f ChangeLog.tmp ; \