summaryrefslogtreecommitdiff
path: root/docs/reference/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'docs/reference/Makefile.am')
-rwxr-xr-xdocs/reference/Makefile.am80
1 files changed, 40 insertions, 40 deletions
diff --git a/docs/reference/Makefile.am b/docs/reference/Makefile.am
index 389a9aba..9b777bcd 100755
--- a/docs/reference/Makefile.am
+++ b/docs/reference/Makefile.am
@@ -6,7 +6,7 @@
AUTOMAKE_OPTIONS = 1.6
# The name of the module, e.g. 'glib'.
-DOC_MODULE=gedit
+DOC_MODULE=pluma
# The top-level SGML file. You can change this if you want to.
DOC_MAIN_SGML_FILE=$(DOC_MODULE)-docs.sgml
@@ -14,7 +14,7 @@ DOC_MAIN_SGML_FILE=$(DOC_MODULE)-docs.sgml
# The directory containing the source code. Relative to $(srcdir).
# gtk-doc will search all .c & .h files beneath here for inline comments
# documenting the functions and macros.
-DOC_SOURCE_DIR=../../gedit
+DOC_SOURCE_DIR=../../pluma
# Extra options to pass to gtkdoc-scangobj. Not normally needed.
SCANGOBJ_OPTIONS=
@@ -35,41 +35,41 @@ MKTMPL_OPTIONS=
FIXXREF_OPTIONS=
# Used for dependencies. The docs will be rebuilt if any of these change.
-HFILE_GLOB=$(top_srcdir)/gedit/*.h
-CFILE_GLOB=$(top_srcdir)/gedit/*.c
+HFILE_GLOB=$(top_srcdir)/pluma/*.h
+CFILE_GLOB=$(top_srcdir)/pluma/*.c
-# Header files to ignore when scanning (These are internal to gedit).
+# Header files to ignore when scanning (These are internal to pluma).
IGNORE_HFILES= \
- gedit-commands.h \
- gedit-document-loader.h \
- gedit-document-saver.h \
- gedit-documents-panel.h \
- gedit-io-error-message-area.h \
- gedit-languages-manager.h \
- gedit-message-area.h \
- gedit-object-module.h \
- gedit-plugin-manager.h \
- gedit-plugins-engine.h \
- gedit-prefs-manager-private.h \
- gedit-session.h \
- gedit-spinner.h \
- gedit-ui.h \
- gedit-window-private.h \
- gedit-output-window.h \
- gedit-close-confirmation-dialog.h \
- gedit-encodings-dialog.h \
- gedit-open-location-dialog.h \
- gedit-page-setup-dialog.h \
- gedit-preferences-dialog.h \
- gedit-search-dialog.h \
- gedit-marshal.h \
- gedit-enum-types.h
-
-# These files are not part of gedit but were copied into it for some reason.
+ pluma-commands.h \
+ pluma-document-loader.h \
+ pluma-document-saver.h \
+ pluma-documents-panel.h \
+ pluma-io-error-message-area.h \
+ pluma-languages-manager.h \
+ pluma-message-area.h \
+ pluma-object-module.h \
+ pluma-plugin-manager.h \
+ pluma-plugins-engine.h \
+ pluma-prefs-manager-private.h \
+ pluma-session.h \
+ pluma-spinner.h \
+ pluma-ui.h \
+ pluma-window-private.h \
+ pluma-output-window.h \
+ pluma-close-confirmation-dialog.h \
+ pluma-encodings-dialog.h \
+ pluma-open-location-dialog.h \
+ pluma-page-setup-dialog.h \
+ pluma-preferences-dialog.h \
+ pluma-search-dialog.h \
+ pluma-marshal.h \
+ pluma-enum-types.h
+
+# These files are not part of pluma but were copied into it for some reason.
# Do not parse them to make the docs.
IGNORE_HFILES += \
bacon-message-connection.h \
- gedittextregion.h \
+ plumatextregion.h \
sexy-icon-entry.h
# Images to copy into HTML directory.
@@ -88,15 +88,15 @@ expand_content_files=
# Only needed if you are using gtkdoc-scangobj to dynamically query widget
# signals and properties.
GTKDOC_CFLAGS= \
- -I$(top_srcdir)/gedit \
- -I$(top_builddir)/gedit \
+ -I$(top_srcdir)/pluma \
+ -I$(top_builddir)/pluma \
-I$(top_srcdir) \
-I$(top_builddir) \
- $(GEDIT_CFLAGS)
+ $(PLUMA_CFLAGS)
GTKDOC_LIBS= \
- $(top_builddir)/gedit/libgedit.la \
- $(GEDIT_LIBS)
+ $(top_builddir)/pluma/libpluma.la \
+ $(PLUMA_LIBS)
if ENABLE_PYTHON
GTKDOC_CFLAGS += \
@@ -105,7 +105,7 @@ GTKDOC_CFLAGS += \
$(PYTHON_CFLAGS) \
$(AM_CFLAGS)
GTKDOC_LIBS += \
- $(top_builddir)/plugin-loaders/python/bindings/gedit.la
+ $(top_builddir)/plugin-loaders/python/bindings/pluma.la
endif
# This includes the standard gtk-doc make rules, copied by gtkdocize.
@@ -115,7 +115,7 @@ include $(top_srcdir)/gtk-doc.make
# e.g. EXTRA_DIST += version.xml.in
regenerate-types:
- grep _get_type $(DOC_SOURCE_DIR)/gedit-*.h | grep -oR '^.*\.h' | sort | uniq - | sed -r 's/^.*\.h$/#include "\0"/' > gedit.types
- grep _get_type $(DOC_SOURCE_DIR)/gedit-*.h | grep -oR '^.*\.h' | sort | uniq - | sed -re 'y/-/_/' -e 's/^(.*)\.h$/\1_get_type/' >> gedit.types.new
+ grep _get_type $(DOC_SOURCE_DIR)/pluma-*.h | grep -oR '^.*\.h' | sort | uniq - | sed -r 's/^.*\.h$/#include "\0"/' > pluma.types
+ grep _get_type $(DOC_SOURCE_DIR)/pluma-*.h | grep -oR '^.*\.h' | sort | uniq - | sed -re 'y/-/_/' -e 's/^(.*)\.h$/\1_get_type/' >> pluma.types.new
-include $(top_srcdir)/git.mk