summaryrefslogtreecommitdiff
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/Makefile.am')
-rwxr-xr-xplugins/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
new file mode 100755
index 00000000..ba80e090
--- /dev/null
+++ b/plugins/Makefile.am
@@ -0,0 +1,42 @@
+DIST_SUBDIRS = \
+ changecase \
+ checkupdate \
+ docinfo \
+ externaltools \
+ filebrowser \
+ modelines \
+ pythonconsole \
+ quickopen \
+ snippets \
+ sort \
+ spell \
+ taglist \
+ time
+
+SUBDIRS = \
+ changecase \
+ docinfo \
+ filebrowser \
+ modelines \
+ sort \
+ taglist \
+ time
+
+if ENABLE_PYTHON
+SUBDIRS += pythonconsole snippets quickopen
+
+if !OS_WIN32
+SUBDIRS += externaltools
+endif
+
+endif
+
+if ENABLE_ENCHANT
+SUBDIRS += spell
+endif
+
+if ENABLE_UPDATER
+SUBDIRS += checkupdate
+endif
+
+-include $(top_srcdir)/git.mk