summaryrefslogtreecommitdiff
path: root/plugins/modelines/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/modelines/Makefile.am')
-rwxr-xr-xplugins/modelines/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/plugins/modelines/Makefile.am b/plugins/modelines/Makefile.am
new file mode 100755
index 00000000..ddcfccc8
--- /dev/null
+++ b/plugins/modelines/Makefile.am
@@ -0,0 +1,38 @@
+# Modelines Plugin
+plugindir = $(GEDIT_PLUGINS_LIBS_DIR)
+
+INCLUDES = \
+ -I$(top_srcdir) \
+ $(GEDIT_CFLAGS) \
+ $(WARN_CFLAGS) \
+ $(DISABLE_DEPRECATED_CFLAGS)
+
+modelinesdir = $(GEDIT_PLUGINS_DATA_DIR)/modelines
+modelines_DATA = \
+ language-mappings
+
+plugin_LTLIBRARIES = libmodelines.la
+
+libmodelines_la_SOURCES = \
+ gedit-modeline-plugin.h \
+ gedit-modeline-plugin.c \
+ modeline-parser.h \
+ modeline-parser.c
+
+libmodelines_la_LDFLAGS = $(PLUGIN_LIBTOOL_FLAGS)
+libmodelines_la_LIBADD = $(GEDIT_LIBS)
+
+plugin_in_files = modelines.gedit-plugin.desktop.in
+%.gedit-plugin: %.gedit-plugin.desktop.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*po) ; $(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
+
+plugin_DATA = $(plugin_in_files:.gedit-plugin.desktop.in=.gedit-plugin)
+
+EXTRA_DIST = \
+ $(plugin_in_files) \
+ $(modelines_DATA)
+
+CLEANFILES = $(plugin_DATA)
+DISTCLEANFILES = $(plugin_DATA)
+
+
+-include $(top_srcdir)/git.mk