summaryrefslogtreecommitdiff
path: root/plugins/pythonconsole/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/pythonconsole/Makefile.am')
-rw-r--r--plugins/pythonconsole/Makefile.am19
1 files changed, 16 insertions, 3 deletions
diff --git a/plugins/pythonconsole/Makefile.am b/plugins/pythonconsole/Makefile.am
index 0a9ff965..51a2e4a4 100644
--- a/plugins/pythonconsole/Makefile.am
+++ b/plugins/pythonconsole/Makefile.am
@@ -7,9 +7,22 @@ plugin_in_files = pythonconsole.plugin.desktop.in
plugin_DATA = $(plugin_in_files:.plugin.desktop.in=.plugin)
-EXTRA_DIST = $(plugin_in_files)
+pythonconsole_gschema_in = org.mate.pluma.plugins.pythonconsole.gschema.xml.in
+gsettings_SCHEMAS = $(pythonconsole_gschema_in:.xml.in=.xml)
+@GSETTINGS_RULES@
-CLEANFILES = $(plugin_DATA)
-DISTCLEANFILES = $(plugin_DATA)
+EXTRA_DIST = \
+ $(plugin_in_files) \
+ $(pythonconsole_gschema_in)
+
+CLEANFILES = \
+ $(plugin_DATA) \
+ $(gsettings_SCHEMAS_in) \
+ $(gsettings_SCHEMAS)
+
+DISTCLEANFILES = \
+ $(plugin_DATA) \
+ $(gsettings_SCHEMAS_in) \
+ $(gsettings_SCHEMAS)
-include $(top_srcdir)/git.mk