summaryrefslogtreecommitdiff
path: root/plugins/pythonconsole/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/pythonconsole/Makefile.am')
-rw-r--r--plugins/pythonconsole/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/plugins/pythonconsole/Makefile.am b/plugins/pythonconsole/Makefile.am
index 51a2e4a4..7c6a02e4 100644
--- a/plugins/pythonconsole/Makefile.am
+++ b/plugins/pythonconsole/Makefile.am
@@ -3,10 +3,11 @@ SUBDIRS = pythonconsole
plugindir = $(PLUMA_PLUGINS_LIBS_DIR)
plugin_in_files = pythonconsole.plugin.desktop.in
-%.plugin: %.plugin.desktop.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*po) ; $(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
-
plugin_DATA = $(plugin_in_files:.plugin.desktop.in=.plugin)
+$(plugin_DATA): $(plugin_in_files)
+ $(AM_V_GEN) $(MSGFMT) --keyword=Name --keyword=Description --desktop --template $< -d $(top_srcdir)/po -o $@
+
pythonconsole_gschema_in = org.mate.pluma.plugins.pythonconsole.gschema.xml.in
gsettings_SCHEMAS = $(pythonconsole_gschema_in:.xml.in=.xml)
@GSETTINGS_RULES@