summaryrefslogtreecommitdiff
path: root/plugins/spell/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/spell/Makefile.am')
-rwxr-xr-xplugins/spell/Makefile.am58
1 files changed, 29 insertions, 29 deletions
diff --git a/plugins/spell/Makefile.am b/plugins/spell/Makefile.am
index 9d332f95..24299165 100755
--- a/plugins/spell/Makefile.am
+++ b/plugins/spell/Makefile.am
@@ -1,59 +1,59 @@
# Spell checker plugin
-plugindir = $(GEDIT_PLUGINS_LIBS_DIR)
+plugindir = $(PLUMA_PLUGINS_LIBS_DIR)
INCLUDES = \
-I$(top_srcdir) \
- $(GEDIT_CFLAGS) \
+ $(PLUMA_CFLAGS) \
$(ENCHANT_CFLAGS) \
$(WARN_CFLAGS) \
$(DISABLE_DEPRECATED_CFLAGS)
BUILT_SOURCES = \
- gedit-spell-marshal.c \
- gedit-spell-marshal.h
+ pluma-spell-marshal.c \
+ pluma-spell-marshal.h
plugin_LTLIBRARIES = libspell.la
libspell_la_SOURCES = \
- gedit-spell-plugin.c \
- gedit-spell-plugin.h \
- gedit-spell-checker.c \
- gedit-spell-checker.h \
- gedit-spell-checker-dialog.c \
- gedit-spell-checker-dialog.h \
- gedit-spell-checker-language.c \
- gedit-spell-checker-language.h \
- gedit-spell-language-dialog.c \
- gedit-spell-language-dialog.h \
- gedit-automatic-spell-checker.c \
- gedit-automatic-spell-checker.h \
- gedit-spell-utils.c \
- gedit-spell-utils.h \
+ pluma-spell-plugin.c \
+ pluma-spell-plugin.h \
+ pluma-spell-checker.c \
+ pluma-spell-checker.h \
+ pluma-spell-checker-dialog.c \
+ pluma-spell-checker-dialog.h \
+ pluma-spell-checker-language.c \
+ pluma-spell-checker-language.h \
+ pluma-spell-language-dialog.c \
+ pluma-spell-language-dialog.h \
+ pluma-automatic-spell-checker.c \
+ pluma-automatic-spell-checker.h \
+ pluma-spell-utils.c \
+ pluma-spell-utils.h \
$(BUILT_SOURCES)
libspell_la_LDFLAGS = $(PLUGIN_LIBTOOL_FLAGS)
-libspell_la_LIBADD = $(GEDIT_LIBS) $(ENCHANT_LIBS)
+libspell_la_LIBADD = $(PLUMA_LIBS) $(ENCHANT_LIBS)
-uidir = $(GEDIT_PLUGINS_DATA_DIR)/spell
+uidir = $(PLUMA_PLUGINS_DATA_DIR)/spell
ui_DATA = spell-checker.ui languages-dialog.ui
-gedit-spell-marshal.h: gedit-spell-marshal.list $(GLIB_GENMARSHAL)
- $(AM_V_GEN) $(GLIB_GENMARSHAL) $< --header --prefix=gedit_marshal > $@
+pluma-spell-marshal.h: pluma-spell-marshal.list $(GLIB_GENMARSHAL)
+ $(AM_V_GEN) $(GLIB_GENMARSHAL) $< --header --prefix=pluma_marshal > $@
-gedit-spell-marshal.c: gedit-spell-marshal.list $(GLIB_GENMARSHAL)
- $(AM_V_GEN) echo "#include \"gedit-spell-marshal.h\"" > $@ && \
- $(GLIB_GENMARSHAL) $< --body --prefix=gedit_marshal >> $@
+pluma-spell-marshal.c: pluma-spell-marshal.list $(GLIB_GENMARSHAL)
+ $(AM_V_GEN) echo "#include \"pluma-spell-marshal.h\"" > $@ && \
+ $(GLIB_GENMARSHAL) $< --body --prefix=pluma_marshal >> $@
-plugin_in_files = spell.gedit-plugin.desktop.in
+plugin_in_files = spell.pluma-plugin.desktop.in
-%.gedit-plugin: %.gedit-plugin.desktop.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*po) ; $(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
+%.pluma-plugin: %.pluma-plugin.desktop.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*po) ; $(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
-plugin_DATA = $(plugin_in_files:.gedit-plugin.desktop.in=.gedit-plugin)
+plugin_DATA = $(plugin_in_files:.pluma-plugin.desktop.in=.pluma-plugin)
EXTRA_DIST = \
$(ui_DATA) \
$(plugin_in_files) \
- gedit-spell-marshal.list
+ pluma-spell-marshal.list
CLEANFILES = $(BUILT_SOURCES) $(plugin_DATA)