summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorYaakov Selkowitz <[email protected]>2012-12-25 04:16:08 -0600
committerStefano Karapetsas <[email protected]>2013-01-22 14:10:34 +0100
commitd63756bd11b097f11f115d5477110893b7ee16a2 (patch)
tree192e7728bc678ff70d7534546adaf9fcb7a8e010 /src/Makefile.am
parentd2c11e9b06b48653e1d0b674eaf8d3230f1ef9bf (diff)
downloadpython-caja-d63756bd11b097f11f115d5477110893b7ee16a2.tar.bz2
python-caja-d63756bd11b097f11f115d5477110893b7ee16a2.tar.xz
Do not dlopen libpython
As libcaja-python is linked with -lpythonX.Y on all platforms, there is no need to dlopen libpython in order to load it.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 49d0e2b..98decaa 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -6,8 +6,6 @@ INCLUDES = \
-I$(top_builddir) \
$(DISABLE_DEPRECATED_CFLAGS) \
$(CAJA_PYTHON_CFLAGS) \
- -DPYTHON_VERSION=\"$(PYTHON_VERSION)\" \
- -DPY_LIB_LOC="\"$(PYTHON_LIB_LOC)\"" \
$(PYTHON_INCLUDES)
caja_extensiondir=$(CAJA_EXTENSION_DIR)
@@ -20,5 +18,5 @@ libcaja_python_la_SOURCES = \
caja-python-object.c \
caja-python-object.h
-libcaja_python_la_LDFLAGS = -module -avoid-version
+libcaja_python_la_LDFLAGS = -module -avoid-version -no-undefined
libcaja_python_la_LIBADD = $(CAJA_PYTHON_LIBS) $(PYTHON_LIBS)