summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPatrick Monnerat <[email protected]>2019-01-19 01:29:22 +0100
committerVictor Kareh <[email protected]>2019-01-30 15:59:28 -0500
commit7c4ff1a2c72b9a4f2a84a2e10c7ea0450dbf5227 (patch)
tree1c99b129c5c8a857237c22e04ea6bdccd12e1577 /src/Makefile.am
parent855e61271bb357b5ccd8beb5541be45ecf62a74f (diff)
downloadpython-caja-7c4ff1a2c72b9a4f2a84a2e10c7ea0450dbf5227.tar.bz2
python-caja-7c4ff1a2c72b9a4f2a84a2e10c7ea0450dbf5227.tar.xz
Include Python 3 ABI flags in shared library name.
Python 3 appends the ABI flags to the version in the shared library file name: since this library is loaded as a gmodule, the correct file name must be provided.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 4203367..0d4e5db 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -15,6 +15,7 @@ libcaja_python_la_CPPFLAGS = \
-DDATADIR=\"$(datadir)\" \
-DLIBDIR=\"$(libdir)\" \
-DPYTHON_VERSION=\"$(PYTHON_VERSION)\" \
+ -DPYTHON_ABIFLAGS=\"$(PYTHON_ABIFLAGS)\" \
-DPY_LIB_LOC="\"$(PYTHON_LIB_LOC)\"" \
$(CAJA_PYTHON_CFLAGS) \
$(AM_CPPFLAGS)