summaryrefslogtreecommitdiff
path: root/backend/comics/Makefile.am
diff options
context:
space:
mode:
authorlukefromdc <[email protected]>2023-12-25 15:11:04 -0500
committerlukefromdc <[email protected]>2024-01-08 23:03:44 -0500
commitaa8e9dad472cbadc96719a8f521768aeeb0913f0 (patch)
tree6bd930efc193fe77be5c74eee725d873a9afdbd5 /backend/comics/Makefile.am
parent658fab1f008bff7e1ec147d95baa04bc44c2fbcd (diff)
downloadatril-aa8e9dad472cbadc96719a8f521768aeeb0913f0.tar.bz2
atril-aa8e9dad472cbadc96719a8f521768aeeb0913f0.tar.xz
comics: Use libarchive to unpack documents
This commit eliminates the use of external commands for opening comic documents, and uses libarchive instead.
Diffstat (limited to 'backend/comics/Makefile.am')
-rw-r--r--backend/comics/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/backend/comics/Makefile.am b/backend/comics/Makefile.am
index b27f9b85..77f3dedb 100644
--- a/backend/comics/Makefile.am
+++ b/backend/comics/Makefile.am
@@ -12,12 +12,15 @@ backend_LTLIBRARIES = libcomicsdocument.la
libcomicsdocument_la_SOURCES = \
comics-document.c \
- comics-document.h
+ comics-document.h \
+ ev-archive.c \
+ ev-archive.h
libcomicsdocument_la_LDFLAGS = $(BACKEND_LIBTOOL_FLAGS)
libcomicsdocument_la_LIBADD = \
$(top_builddir)/libdocument/libatrildocument.la \
$(BACKEND_LIBS) \
+ $(COMICS_LIBS) \
$(LIB_LIBS)
backend_in_files = comicsdocument.atril-backend.desktop.in