summaryrefslogtreecommitdiff
path: root/backend/comics/Makefile.am
diff options
context:
space:
mode:
authorlukefromdc <[email protected]>2023-12-25 15:11:04 -0500
committerLuke from DC <[email protected]>2024-01-07 22:17:05 +0000
commitce41df6467521ff9fd4f16514ae7d6ebb62eb1ed (patch)
tree9f4ac5a7fac935d9c81fbe489517eecdc408667c /backend/comics/Makefile.am
parent600b552f162fa6b59a937be541d8a377807bcceb (diff)
downloadatril-ce41df6467521ff9fd4f16514ae7d6ebb62eb1ed.tar.bz2
atril-ce41df6467521ff9fd4f16514ae7d6ebb62eb1ed.tar.xz
comics: Use libarchive to unpack documents
This commit eliminates the use of external commands for opening comic documents, and uses libarchive instead.
Diffstat (limited to 'backend/comics/Makefile.am')
-rw-r--r--backend/comics/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/backend/comics/Makefile.am b/backend/comics/Makefile.am
index b27f9b85..77f3dedb 100644
--- a/backend/comics/Makefile.am
+++ b/backend/comics/Makefile.am
@@ -12,12 +12,15 @@ backend_LTLIBRARIES = libcomicsdocument.la
libcomicsdocument_la_SOURCES = \
comics-document.c \
- comics-document.h
+ comics-document.h \
+ ev-archive.c \
+ ev-archive.h
libcomicsdocument_la_LDFLAGS = $(BACKEND_LIBTOOL_FLAGS)
libcomicsdocument_la_LIBADD = \
$(top_builddir)/libdocument/libatrildocument.la \
$(BACKEND_LIBS) \
+ $(COMICS_LIBS) \
$(LIB_LIBS)
backend_in_files = comicsdocument.atril-backend.desktop.in