summaryrefslogtreecommitdiff
path: root/backend/dvi/mdvi-lib/meson.build
diff options
context:
space:
mode:
authorOz Tiram <[email protected]>2025-03-30 15:20:05 +0200
committerLuke from DC <[email protected]>2025-04-04 22:19:13 +0000
commitb1f21edcec82c25cbd6b59b521a841f86fb1f327 (patch)
tree57bed53a768722d58d0d4c081be54198f90d6cb6 /backend/dvi/mdvi-lib/meson.build
parent0672f82ffb2e56ffb711703b3b786714d2bc794c (diff)
downloadatril-b1f21edcec82c25cbd6b59b521a841f86fb1f327.tar.bz2
atril-b1f21edcec82c25cbd6b59b521a841f86fb1f327.tar.xz
Initial support for meson
Mostly copy and paste from linuxmint/xreader Signed-off-by: Oz Tiram <[email protected]>
Diffstat (limited to 'backend/dvi/mdvi-lib/meson.build')
-rw-r--r--backend/dvi/mdvi-lib/meson.build67
1 files changed, 67 insertions, 0 deletions
diff --git a/backend/dvi/mdvi-lib/meson.build b/backend/dvi/mdvi-lib/meson.build
new file mode 100644
index 00000000..6b9848ba
--- /dev/null
+++ b/backend/dvi/mdvi-lib/meson.build
@@ -0,0 +1,67 @@
+mdvi_sources = [
+ 'afmparse.c',
+ 'afmparse.h',
+ 'bitmap.c',
+ 'bitmap.h',
+ 'color.c',
+ 'color.h',
+ 'common.c',
+ 'common.h',
+ 'defaults.h',
+ 'dviopcodes.h',
+ 'dviread.c',
+ 'files.c',
+ 'font.c',
+ 'fontmap.c',
+ 'fontmap.h',
+ 'fontsrch.c',
+ 'gf.c',
+ 'hash.c',
+ 'hash.h',
+ 'list.c',
+ 'mdvi.h',
+ 'pagesel.c',
+ 'paper.c',
+ 'paper.h',
+ 'pk.c',
+ 'private.h',
+ 'setup.c',
+ 'special.c',
+ 'sp-epsf.c',
+ 'sysdeps.h',
+ 't1.c',
+ 'tfm.c',
+ 'tfmfile.c',
+ 'tt.c',
+ 'util.c',
+ 'vf.c',
+]
+
+mdvi_c_args = [
+ '-DSIZEOF_INT=__SIZEOF_INT__',
+ '-DSIZEOF_LONG=__SIZEOF_LONG__',
+ '-DSIZEOF_SHORT=__SIZEOF_SHORT__',
+ '-DSIZEOF_VOID_P=__SIZEOF_POINTER__',
+]
+
+mdvi_deps = [
+ kpathsea,
+]
+
+if t1_enabled
+ mdvi_c_args += '-DWITH_TYPE1_FONTS'
+ mdvi_deps += t1lib
+endif
+
+libmdvi = static_library(
+ 'mdvi',
+ mdvi_sources,
+ c_args: mdvi_c_args,
+ include_directories: include_dirs,
+ dependencies: mdvi_deps,
+)
+
+libmdvi_dep = declare_dependency(
+ include_directories: include_directories('.'),
+ link_with: libmdvi,
+)