summaryrefslogtreecommitdiff
path: root/backend/tiff/meson.build
diff options
context:
space:
mode:
authorOz Tiram <[email protected]>2025-03-30 15:20:05 +0200
committerLuke from DC <[email protected]>2025-04-04 22:19:13 +0000
commitb1f21edcec82c25cbd6b59b521a841f86fb1f327 (patch)
tree57bed53a768722d58d0d4c081be54198f90d6cb6 /backend/tiff/meson.build
parent0672f82ffb2e56ffb711703b3b786714d2bc794c (diff)
downloadatril-b1f21edcec82c25cbd6b59b521a841f86fb1f327.tar.bz2
atril-b1f21edcec82c25cbd6b59b521a841f86fb1f327.tar.xz
Initial support for meson
Mostly copy and paste from linuxmint/xreader Signed-off-by: Oz Tiram <[email protected]>
Diffstat (limited to 'backend/tiff/meson.build')
-rw-r--r--backend/tiff/meson.build34
1 files changed, 34 insertions, 0 deletions
diff --git a/backend/tiff/meson.build b/backend/tiff/meson.build
new file mode 100644
index 00000000..b0eb52bf
--- /dev/null
+++ b/backend/tiff/meson.build
@@ -0,0 +1,34 @@
+tiff_sources = [
+ 'tiff-document.c',
+ 'tiff-document.h',
+ 'tiff2ps.c',
+ 'tiff2ps.h',
+]
+
+tiff_deps = [
+ cairo,
+ glib,
+ gtk,
+ math,
+ tiff,
+]
+
+shared_module(
+ 'tiffdocument',
+ tiff_sources,
+ link_with: [libdocument],
+ link_args: ['-Wl,-Bsymbolic', '-Wl,-z,relro', '-Wl,-z,now'],
+ include_directories: include_dirs,
+ dependencies: tiff_deps,
+ install: true,
+ install_dir: backendsdir,
+)
+
+custom_target(
+ 'tiff_backend',
+ input: 'tiffdocument.atril-backend.desktop.in',
+ output: 'tiffdocument.atril-backend',
+ command: [intltool_merge, '-d', '-u', po_dir, '@INPUT@', '@OUTPUT@'],
+ install: true,
+ install_dir: backendsdir,
+)