summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrootavish <[email protected]>2014-05-30 21:57:13 +0530
committerrootavish <[email protected]>2014-05-30 22:23:05 +0530
commit415b008bff9de46176ed39daa2ffece45cdd2506 (patch)
tree53d6b70cd67eda8cf79b84809db90fef5ddc80aa /configure.ac
parent7f33c3425aae32d1dd5d2d7b912f8d4eac1cf85d (diff)
downloadatril-415b008bff9de46176ed39daa2ffece45cdd2506.tar.bz2
atril-415b008bff9de46176ed39daa2ffece45cdd2506.tar.xz
Created a Makefile for minizip, modified epub Makefile
I created a Makefile for the minizip backend, since i am only using part of that library and modified the epub backend to work with the library. Also modified the configure script to suit our purpose. The epub backend can now be compiled using the make command in the epub directory, although it cannot still be compiled as a part of atril.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index baa7ffd2..e4365af8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -699,7 +699,7 @@ AC_ARG_ENABLE(epub,
if test "x$enable_epub" = "xyes"; then
WEBKIT_REQUIRED=2.4.2
- PKG_CHECK_MODULES(WEBKIT, webkit2gtk-3.0 >= $WEBKIT_REQUIRED,enable_epub=yes,enable_epub=no)
+ PKG_CHECK_MODULES(WEBKIT, webkit2gtk-3.0 >= $WEBKIT_REQUIRED libxml-2.0 >= $LIBXML_REQUIRED zlib,enable_epub=yes,enable_epub=no)
if test "x$enable_epub" = "xyes"; then
AC_DEFINE([ENABLE_EPUB], [1], [Enable support for ePub documents.])
@@ -796,6 +796,7 @@ backend/djvu/Makefile
backend/dvi/Makefile
backend/dvi/mdvi-lib/Makefile
backend/epub/Makefile
+backend/epub/minizip/Makefile
backend/pdf/Makefile
backend/pixbuf/Makefile
backend/ps/Makefile