summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2013-08-02 00:56:12 +0200
committerStefano Karapetsas <[email protected]>2013-08-02 00:56:12 +0200
commit5b333c09f2de21e55c0b32eb303526cb30f7927f (patch)
tree7e615c8f16e3d8cb58ba9b7aa42dff068f1b350c /configure.ac
parent7c344728b1186266be690616ffb7e9c65df495af (diff)
parentd92405a6604531f757de8b13acb43f5a49fe63c9 (diff)
downloadatril-5b333c09f2de21e55c0b32eb303526cb30f7927f.tar.bz2
atril-5b333c09f2de21e55c0b32eb303526cb30f7927f.tar.xz
Merge branch 'dev-libsecret'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index d2a4b871..fd2ec897 100644
--- a/configure.ac
+++ b/configure.ac
@@ -133,7 +133,7 @@ AC_MSG_RESULT([$with_gtk])
dnl Specify required versions of dependencies
CAIRO_REQUIRED=1.9.10
GLIB_REQUIRED=2.25.11
-KEYRING_REQUIRED=1.1.0
+LIBSECRET_REQUIRED=0.5
case "$with_gtk" in
2.0) GTK_API_VERSION=2.0
@@ -268,12 +268,12 @@ if test "$with_gtk_unix_print" = "yes"; then
fi
# *********************
-# MATE Keyring support
+# Keyring support
# *********************
AC_ARG_WITH(keyring,
[AS_HELP_STRING([--without-keyring],
- [Disable the use of mate-keyring])],
+ [Disable the use of libsecret and keyring])],
[],
[case "$with_platform" in
mate) with_keyring=yes ;;
@@ -283,7 +283,7 @@ AC_ARG_WITH(keyring,
AM_CONDITIONAL([WITH_KEYRING],[test "$with_keyring" = "yes"])
if test "$with_keyring" = "yes"; then
- PKG_CHECK_MODULES(KEYRING, mate-keyring-1 >= $KEYRING_REQUIRED)
+ PKG_CHECK_MODULES(LIBSECRET, libsecret-1 >= $LIBSECRET_REQUIRED)
AC_DEFINE([WITH_KEYRING],[1],[Define if KEYRING support is enabled])
fi
@@ -341,8 +341,8 @@ BACKEND_LIBS="$BACKEND_LIBS -lm"
AC_SUBST(BACKEND_CFLAGS)
AC_SUBST(BACKEND_LIBS)
-SHELL_CFLAGS="$SHELL_CORE_CFLAGS $KEYRING_CFLAGS -DGDK_MULTIHEAD_SAFE -DGTK_MULTIHEAD_SAFE $DEBUG_FLAGS"
-SHELL_LIBS="$SHELL_CORE_LIBS $KEYRING_LIBS -lz -lm"
+SHELL_CFLAGS="$SHELL_CORE_CFLAGS $LIBSECRET_CFLAGS -DGDK_MULTIHEAD_SAFE -DGTK_MULTIHEAD_SAFE $DEBUG_FLAGS"
+SHELL_LIBS="$SHELL_CORE_LIBS $LIBSECRET_LIBS -lz -lm"
AC_SUBST(SHELL_CFLAGS)
AC_SUBST(SHELL_LIBS)