summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorinfirit <[email protected]>2013-08-10 14:43:17 +0200
committerinfirit <[email protected]>2013-08-10 14:43:17 +0200
commita8b9cc1a18765d7ebca5c963410edf0e2eff5399 (patch)
tree986645110346f40ecd429e59565bb7f709930e1d /configure.ac
parent05dcc3342e422a06cabe469ddde878e726c483a3 (diff)
downloadatril-a8b9cc1a18765d7ebca5c963410edf0e2eff5399.tar.bz2
atril-a8b9cc1a18765d7ebca5c963410edf0e2eff5399.tar.xz
Add check for zlib and add to linker
Should solve https://bugs.gentoo.org/show_bug.cgi?id=480464 and https://github.com/Sabayon/mate-overlay/issues/46
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7250149a..0e7ae4f0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -196,6 +196,20 @@ esac
PKG_CHECK_MODULES([SHELL_CORE],[libxml-2.0 >= $LIBXML_REQUIRED gtk+-$GTK_API_VERSION >= $GTK_REQUIRED gio-2.0 >= $GLIB_REQUIRED gthread-2.0 $SHELL_PLATFORM_PKGS])
+dnl
+dnl zlib support
+dnl
+
+PKG_CHECK_MODULES([ZLIB], [zlib], [found_zlib=yes], [found_zlib=no])
+AS_IF([test "x$found_zlib" = "xno"], [
+ AC_CHECK_LIB(z, inflate, [AC_CHECK_HEADER(zlib.h, found_zlib=yes)])
+ if test "x$found_zlib" = "xno" ; then
+ AC_MSG_ERROR([*** Working zlib library and headers not found ***])
+ fi
+ ZLIB_LIBS='-lz'
+ AC_SUBST(ZLIB_LIBS)
+])
+
# *********
# SM client
# *********