summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrootavish <[email protected]>2014-06-19 14:19:48 +0530
committerrootavish <[email protected]>2014-06-19 14:19:48 +0530
commitd57fa16e9e8c9091ebf826af94a0c3ad1a593596 (patch)
tree3969514d475a92c977fa15ee7e19ac37d5fe3575 /configure.ac
parent3fd3e5708b0566b1392fa5e7f37a18de137a43e0 (diff)
downloadatril-d57fa16e9e8c9091ebf826af94a0c3ad1a593596.tar.bz2
atril-d57fa16e9e8c9091ebf826af94a0c3ad1a593596.tar.xz
Epub backend builds as a part of Atril compilation
Fixed a tabbing error in backend/Makefile.am due to which the epub backend was not a target when building recursilvely, i am not commiting the changes to epub-document.c as currently it will break the build, hope to fix it and get webkit and mathjax done by the weekend. Also fixed an error in configure.ac wherin the appearance of AM_LIBTOOL_PROG before AC_CXX_PROG caused a "link:unsupported hardcode properties error" on Linux Mint.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index e4365af8..19bc4ba4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -53,14 +53,14 @@ AM_MAINTAINER_MODE([enable])
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
-AM_PROG_LIBTOOL
+
AC_ISC_POSIX
AC_PROG_CC
AM_PROG_CC_C_O
AC_PROG_CXX
AC_STDC_HEADERS
-
+AM_PROG_LIBTOOL
AC_PROG_SED
AC_PATH_PROG([GLIB_GENMARSHAL], [glib-genmarshal])
AC_PATH_PROG([GLIB_MKENUMS], [glib-mkenums])
@@ -693,7 +693,7 @@ dnl ================== EPUB checks =============================================
dnl TODO : complete this once library dependencies are added and finalized
AC_ARG_ENABLE(epub,
[AS_HELP_STRING([--enable-epub],
- [Compile with support for ePub documents.])],
+ [Compile with support for epub documents.])],
[enable_epub=$enableval],
[enable_epub=yes])