summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrootavish <[email protected]>2014-07-01 20:29:05 +0530
committerrootavish <[email protected]>2014-07-01 20:29:05 +0530
commite10bf9631652b8533b18a14285db89bd14b4c42e (patch)
treea0a9c36c3712a3e0d3b0a548a2b2a1bb08e6060d /configure.ac
parent5028995e3725c264b2487a1101c22e941b04c8fd (diff)
downloadatril-e10bf9631652b8533b18a14285db89bd14b4c42e.tar.bz2
atril-e10bf9631652b8533b18a14285db89bd14b4c42e.tar.xz
More changes to accomodate webview
- Modified configure.ac to use both webkit2 and webkit1 based on gtk version - Modified Automake file in help/reference/shell/Makefile.am to compile with gtk-doc - Modified ev-document-model to support epub-documents. - Modified ev-window for epub documents. - Modified jobs so epub pages are not rendered. - Modified ev-document, although I'm not sure if this is necessary. Still need to figure out where the web view load uri has to be called to actually load pages, from there the puzzle would be much simpler. Hope to get this done in the week, and pick up the pace now that only six weeks of coding remain before final evaluation.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 17 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index b7d1070a..fc297187 100644
--- a/configure.ac
+++ b/configure.ac
@@ -690,7 +690,7 @@ dnl ================== End of XPS checks =======================================
dnl ================== EPUB checks ===================================================
-dnl TODO : complete this once library dependencies are added and finalized
+
AC_ARG_ENABLE(epub,
[AS_HELP_STRING([--enable-epub],
[Compile with support for epub documents.])],
@@ -699,13 +699,26 @@ AC_ARG_ENABLE(epub,
if test "x$enable_epub" = "xyes"; then
WEBKIT_REQUIRED=2.4.2
- PKG_CHECK_MODULES(WEBKIT, webkit-1.0 >= $WEBKIT_REQUIRED libxml-2.0 >= $LIBXML_REQUIRED zlib,enable_epub=yes,enable_epub=no)
-
- if test "x$enable_epub" = "xyes"; then
+ case "$with_gtk" in
+ 2.0)
+ PKG_CHECK_MODULES(WEBKIT, webkit-1.0 >= $WEBKIT_REQUIRED libxml-2.0 >= $LIBXML_REQUIRED zlib,enable_epub=yes,enable_epub=no)
+ ;;
+ 3.0)
+ PKG_CHECK_MODULES(WEBKIT, webkit2gtk-3.0 >= $WEBKIT_REQUIRED libxml-2.0 >= $LIBXML_REQUIRED zlib,enable_epub=yes,enable_epub=no)
+ ;;
+ esac
+ if test "x$enable_epub" = "xyes"; then
AC_DEFINE([ENABLE_EPUB], [1], [Enable support for ePub documents.])
else
enable_epub="no"
AC_MSG_WARN(["ePub support is disabled since webkit-1.0( version >= $WEBKIT_REQUIRED ) is needed"])
+ case "$with_gtk" in
+ 2.0)
+ AC_MSG_WARN(["ePub support is disabled since webkit-1.0( version >= $WEBKIT_REQUIRED ) is needed"])
+ ;;
+ 3.0)AC_MSG_WARN(["ePub support is disabled since webkit2gtk-3.0( version >= $WEBKIT_REQUIRED ) is needed"])
+ ;;
+ esac
fi
fi