summaryrefslogtreecommitdiff
path: root/libview/Makefile.am
diff options
context:
space:
mode:
authorrootavish <[email protected]>2014-07-07 18:36:55 +0530
committerrootavish <[email protected]>2014-07-07 18:36:55 +0530
commitdf43418e209ae9c98844185f789c63769ae9b3a2 (patch)
tree40b713aaa4b1596c1d6ccddbe89486983d093881 /libview/Makefile.am
parent6f41c201422edd6b4dbf9f9f41b5dc29530d21c6 (diff)
downloadatril-df43418e209ae9c98844185f789c63769ae9b3a2.tar.bz2
atril-df43418e209ae9c98844185f789c63769ae9b3a2.tar.xz
Refactored code, created a new EvWebView type
Earlier my approach was to replace the atril view directly with a webview. However as it turned out it was extremely difficult to accomplish much tasks without the document-model. So I created an Extension of the WebKitWebView class, EvWebView so that now we can manipulate the webview as desired. Also having a separate file really helps in terms of clarity. Please note that there are many empty functions and TODO tags right now, I shall aim to fill these up once the display part is done, probably in this week. I also added some code on the backend to draw thumbnails when with GTK+-3.0, although I have never tested a GTK+-3.0 build.With GTK+-2.0 you won't get any build errors, however epub backend won't work right now. That being said, this commit is mostly because there was a lot of code that was lying in the local repository, and it was best to back it up as a failsafe. I modified ev-window to accomodate this new data structure, and having an equivalent ev_web_view function for every ev_view function, I can achieve most functionality by filling those functions with Webkit modules. Other than that on the backend Other than that there were some minor changes to the code. Although I did the above, currently I am not able to instantiate the EvWebView because of some class and object type definition errors, due to which I can't display the document.
Diffstat (limited to 'libview/Makefile.am')
-rw-r--r--libview/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/libview/Makefile.am b/libview/Makefile.am
index 7dd0a950..a5d28360 100644
--- a/libview/Makefile.am
+++ b/libview/Makefile.am
@@ -19,6 +19,7 @@ INST_H_SRC_FILES = \
ev-print-operation.h \
ev-stock-icons.h \
ev-view.h \
+ ev-web-view.h \
ev-view-presentation.h
INST_H_FILES = \
@@ -41,6 +42,7 @@ libatrilview_la_SOURCES = \
ev-timeline.c \
ev-transition-animation.c \
ev-view.c \
+ ev-web-view.c \
ev-view-accessible.c \
ev-view-marshal.c \
ev-view-cursor.c \
@@ -63,6 +65,7 @@ libatrilview_la_CFLAGS = \
$(LIBVIEW_CFLAGS) \
$(WARN_CFLAGS) \
$(DISABLE_DEPRECATED) \
+ $(WEBKIT_CFLAGS) \
$(AM_CFLAGS)
libatrilview_la_LDFLAGS = \
@@ -73,7 +76,8 @@ libatrilview_la_LDFLAGS = \
libatrilview_la_LIBADD = \
$(top_builddir)/libdocument/libatrildocument.la \
- $(LIBVIEW_LIBS)
+ $(LIBVIEW_LIBS) \
+ $(WEBKIT_CFLAGS)
BUILT_SOURCES = \
ev-view-marshal.h \