summaryrefslogtreecommitdiff
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorinfirit <[email protected]>2015-07-28 12:37:53 +0200
committerinfirit <[email protected]>2015-07-28 12:37:53 +0200
commit37abef2d6b86de04b6ae54a79e89b58304ae4762 (patch)
treec707597659753025010de4e22a13c4d42efddc09 /shell/Makefile.am
parent2dc3ae141afe190aa646b8062ea561416120d080 (diff)
downloadatril-37abef2d6b86de04b6ae54a79e89b58304ae4762.tar.bz2
atril-37abef2d6b86de04b6ae54a79e89b58304ae4762.tar.xz
Fix build with optional mate-desktop.
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 0f82bde5..bc29d864 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -19,6 +19,7 @@ AM_CPPFLAGS= \
-DLIBEXECDIR=\""$(libexecdir)"\" \
-DATRIL_COMPILATION \
$(SHELL_CFLAGS) \
+ $(MATE_DESKTOP_CFLAGS) \
$(WARN_CFLAGS) \
$(DISABLE_DEPRECATED)
@@ -115,7 +116,8 @@ atril_LDADD= \
$(top_builddir)/libdocument/libatrildocument.la \
$(top_builddir)/libview/libatrilview.la \
$(top_builddir)/libmisc/libevmisc.la \
- $(SHELL_LIBS)
+ $(SHELL_LIBS) \
+ $(MATE_DESKTOP_LIBS)
if PLATFORM_WIN32
atril_LDADD += atril-icon.o