summaryrefslogtreecommitdiff
path: root/backend/pdf/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'backend/pdf/meson.build')
-rw-r--r--backend/pdf/meson.build30
1 files changed, 30 insertions, 0 deletions
diff --git a/backend/pdf/meson.build b/backend/pdf/meson.build
new file mode 100644
index 00000000..7fd40eda
--- /dev/null
+++ b/backend/pdf/meson.build
@@ -0,0 +1,30 @@
+pdf_sources = [
+ 'ev-poppler.cc',
+ 'ev-poppler.h'
+]
+
+pdf_deps = [
+ gtk,
+ xml,
+ poppler,
+]
+
+shared_module(
+ 'pdfdocument',
+ pdf_sources,
+ link_with: [libdocument],
+ link_args: ['-Wl,-Bsymbolic', '-Wl,-z,relro', '-Wl,-z,now'],
+ include_directories: include_dirs,
+ dependencies: pdf_deps,
+ install: true,
+ install_dir: backendsdir,
+)
+
+custom_target(
+ 'pdf_backend',
+ input: 'pdfdocument.atril-backend.desktop.in',
+ output: 'pdfdocument.atril-backend',
+ command: [intltool_merge, '-d', '-u', po_dir, '@INPUT@', '@OUTPUT@'],
+ install: true,
+ install_dir: backendsdir,
+)