summaryrefslogtreecommitdiff
path: root/cut-n-paste/zoom-control/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'cut-n-paste/zoom-control/meson.build')
-rw-r--r--cut-n-paste/zoom-control/meson.build28
1 files changed, 28 insertions, 0 deletions
diff --git a/cut-n-paste/zoom-control/meson.build b/cut-n-paste/zoom-control/meson.build
new file mode 100644
index 00000000..2c3320ac
--- /dev/null
+++ b/cut-n-paste/zoom-control/meson.build
@@ -0,0 +1,28 @@
+zoom_sources = [
+ 'ephy-zoom-action.h',
+ 'ephy-zoom-action.c',
+ 'ephy-zoom-control.c',
+ 'ephy-zoom-control.h',
+ 'ephy-zoom.c',
+ 'ephy-zoom.h',
+]
+
+zoom_deps = [
+ config_h,
+ glib,
+ gtk,
+ math
+]
+
+libephyzoom = static_library(
+ 'libephyzoom',
+ zoom_sources,
+ include_directories: include_root,
+ dependencies: zoom_deps,
+)
+
+libephyzoom_dep = declare_dependency(
+ link_with: libephyzoom,
+ include_directories: [include_root, include_directories('.')],
+ dependencies: zoom_deps,
+)