summaryrefslogtreecommitdiff
path: root/install-scripts/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'install-scripts/meson.build')
-rw-r--r--install-scripts/meson.build21
1 files changed, 21 insertions, 0 deletions
diff --git a/install-scripts/meson.build b/install-scripts/meson.build
new file mode 100644
index 00000000..e27404dd
--- /dev/null
+++ b/install-scripts/meson.build
@@ -0,0 +1,21 @@
+# These scripts run as post-installation scripts.
+
+# They're designed to do nothing if DESTDIR is set, which happens
+# during debian builds for instance - there's a fake install target
+# so running these would be pointless.
+
+# When using deb packaging, these aren't needed, as these operations
+# are run automatically by the package manager.
+
+# They're really only necessary in straight builds where 'ninja install'
+# will be run directly, to install the program onto the system.
+
+
+# Re-compile gsettings
+meson.add_install_script('meson_install_schemas.py')
+
+# Update mime info
+meson.add_install_script('meson_update_mime_database.py')
+
+# Update the Gtk icon cache
+meson.add_install_script('meson_update_icon_cache.py')