summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorXiaotian Wu <[email protected]>2023-10-16 10:42:27 +0800
committerraveit65 <[email protected]>2023-10-24 09:21:51 +0200
commit1d21084e8ffdacb3e3b60840261b6d456d23887e (patch)
tree5a7a8cbc8b694e1b3c91c3ee034723691afdc150 /configure.ac
parent282756dbfaca7984af2f74f9c2b8417e27c5c85e (diff)
downloadcaja-extensions-1d21084e8ffdacb3e3b60840261b6d456d23887e.tar.bz2
caja-extensions-1d21084e8ffdacb3e3b60840261b6d456d23887e.tar.xz
sendto: require gupnp-1.6
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index c8fb513..8df589a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -119,7 +119,7 @@ if test "x$enable_sendto" = "xyes"; then
GTHREAD_REQUIRED=2.6.0
DBUS_REQUIRED=1.0
DBUS_GLIB_REQUIRED=0.60
- GUPNP_REQUIRED=0.13
+ GUPNP_REQUIRED=1.6
PKG_CHECK_MODULES(SENDTO,
glib-2.0 >= $GLIB_REQUIRED
gthread-2.0 >= $GTHREAD_REQUIRED
@@ -233,9 +233,7 @@ if test "x$enable_sendto" = "xyes"; then
fi
;;
upnp)
- PKG_CHECK_MODULES(UPNP, gupnp-1.2 >= $GUPNP_REQUIRED,
- enable_upnp=yes AC_DEFINE([HAS_GUPNP_VERSION_1_2], 1, ["Version is at least 1.2"]), enable_upnp=no)
- PKG_CHECK_MODULES(UPNP, gupnp-1.0 >= $GUPNP_REQUIRED,
+ PKG_CHECK_MODULES(UPNP, gupnp-1.6 >= $GUPNP_REQUIRED,
enable_upnp=yes, enable_upnp=no)
if test "${enable_upnp}" != "yes" ; then
sendto_plugin_error_or_ignore "you need gupnp installed to build the upnp plugin"