summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 27 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 14e2164..6957c69 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-AC_INIT([caja-extensions], 1.25.1, [https://github.com/mate-desktop/caja-extensions], [caja-extensions], [https://mate-desktop.org])
+AC_INIT([caja-extensions], 1.28.0, [https://github.com/mate-desktop/caja-extensions], [caja-extensions], [https://mate-desktop.org])
AM_INIT_AUTOMAKE([1.9 no-dist-gzip dist-xz tar-ustar check-news])
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
@@ -57,6 +57,25 @@ PKG_CHECK_MODULES(CAJA,
AC_SUBST(CAJA_CFLAGS)
AC_SUBST(CAJA_LIBS)
+# av extension
+AC_ARG_ENABLE([av],
+ AS_HELP_STRING([--enable-totem-properties], [Enable AV plugin]),
+ [enable_totem_properties=$enableval],
+ [enable_totem_properties=yes])
+
+if test "x$enable_totem_properties" = "xyes"; then
+ PKG_CHECK_MODULES(TOTEM_PROPERTIES,
+ gstreamer-tag-1.0
+ gstreamer-pbutils-1.0
+ gtk+-3.0 >= $GTK_REQUIRED
+ glib-2.0 >= $GLIB_REQUIRED
+ gio-2.0 >= $GLIB_REQUIRED)
+ AC_SUBST(TOTEM_PROPERTIES_CFLAGS)
+ AC_SUBST(TOTEM_PROPERTIES_LIBS)
+fi
+
+AM_CONDITIONAL(ENABLE_TOTEM_PROPERTIES, test x"$enable_totem_properties" = "xyes")
+
# image-converter extension
AC_ARG_ENABLE([image-converter],
AS_HELP_STRING([--enable-image-converter], [Enable image-converter plugin]),
@@ -100,7 +119,7 @@ if test "x$enable_sendto" = "xyes"; then
GTHREAD_REQUIRED=2.6.0
DBUS_REQUIRED=1.0
DBUS_GLIB_REQUIRED=0.60
- GUPNP_REQUIRED=0.13
+ GUPNP_REQUIRED=1.6
PKG_CHECK_MODULES(SENDTO,
glib-2.0 >= $GLIB_REQUIRED
gthread-2.0 >= $GTHREAD_REQUIRED
@@ -214,9 +233,7 @@ if test "x$enable_sendto" = "xyes"; then
fi
;;
upnp)
- PKG_CHECK_MODULES(UPNP, gupnp-1.2 >= $GUPNP_REQUIRED,
- enable_upnp=yes AC_DEFINE([HAS_GUPNP_VERSION_1_2], 1, ["Version is at least 1.2"]), enable_upnp=no)
- PKG_CHECK_MODULES(UPNP, gupnp-1.0 >= $GUPNP_REQUIRED,
+ PKG_CHECK_MODULES(UPNP, gupnp-1.6 >= $GUPNP_REQUIRED,
enable_upnp=yes, enable_upnp=no)
if test "${enable_upnp}" != "yes" ; then
sendto_plugin_error_or_ignore "you need gupnp installed to build the upnp plugin"
@@ -336,8 +353,10 @@ AM_CONDITIONAL([USE_NLS], [test "x${USE_NLS}" = "xyes"])
DISABLE_DEPRECATED_CPPFLAGS="-DG_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED"
AC_SUBST(DISABLE_DEPRECATED_CPPFLAGS)
-AC_OUTPUT([
+AC_CONFIG_FILES([
Makefile
+ audio-video-properties/Makefile
+ audio-video-properties/libcaja-av.caja-extension.desktop.in
sendto/org.mate.Caja.Sendto.gschema.xml
open-terminal/org.mate.caja-open-terminal.gschema.xml
gksu/libcaja-gksu.caja-extension.desktop.in
@@ -366,6 +385,7 @@ AC_OUTPUT([
xattr-tags/Makefile
po/Makefile.in
])
+AC_OUTPUT
echo "
Configure summary:
@@ -381,6 +401,7 @@ Configure summary:
Plugins to be built
`echo "Plugins to be built" | sed "s/./=/g"`
+ Audio Video Properties: $enable_totem_properties
Image Converter: $enable_image_converter
Open Terminal: $enable_open_terminal
Sendto: $enable_sendto