summaryrefslogtreecommitdiff
path: root/sendto/plugins/pidgin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sendto/plugins/pidgin/Makefile.am')
-rw-r--r--sendto/plugins/pidgin/Makefile.am42
1 files changed, 28 insertions, 14 deletions
diff --git a/sendto/plugins/pidgin/Makefile.am b/sendto/plugins/pidgin/Makefile.am
index bcfe1d3..e6e64bc 100644
--- a/sendto/plugins/pidgin/Makefile.am
+++ b/sendto/plugins/pidgin/Makefile.am
@@ -1,20 +1,34 @@
-plugindir = $(libdir)/caja-sendto/plugins
+NULL =
+
+AM_CPPFLAGS = \
+ $(DISABLE_DEPRECATED_CPPFLAGS) \
+ -DMATELOCALEDIR=\""$(datadir)/locale"\" \
+ -I$(top_builddir) \
+ -I$(top_srcdir)/sendto \
+ $(NULL)
-AM_CPPFLAGS = \
- -DDATADIR=\"$(datadir)\" \
- -DICONDIR=\"$(icondir)\" \
- -DLOCALEDIR="\"$(datadir)/locale\"" \
- -I$(top_srcdir)/sendto \
- -I$(top_builddir) \
- $(SENDTO_CFLAGS) \
- $(NST_EBOOK_CFLAGS) \
- $(PIDGIN_CFLAGS) \
- $(DISABLE_DEPRECATED) \
- $(WARN_CFLAGS)
+AM_CFLAGS = \
+ $(WARN_CFLAGS) \
+ $(SENDTO_CFLAGS) \
+ $(NULL)
+
+plugindir = $(libdir)/caja-sendto/plugins
plugin_LTLIBRARIES = libnstpidgin.la
libnstpidgin_la_SOURCES = pidgin.c
+libnstpidgin_la_CPPFLAG = \
+ $(AM_CFLAGS) \
+ -DDATADIR=\"$(datadir)\" \
+ -DICONDIR=\"$(icondir)\" \
+ $(NULL)
+libnstpidgin_la_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(NST_EBOOK_CFLAGS) \
+ $(PIDGIN_CFLAGS) \
+ $(NULL)
libnstpidgin_la_LDFLAGS = -module -avoid-version
-libnstpidgin_la_LIBADD = $(PIDGIN_LIBS) $(SENDTO_LIBS)
-
+libnstpidgin_la_LIBADD = \
+ $(PIDGIN_LIBS) \
+ $(SENDTO_LIBS) \
+ $(NUll)