summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorlukefromdc <[email protected]>2016-10-14 16:28:27 -0400
committerlukefromdc <[email protected]>2016-10-14 16:28:27 -0400
commita4822f6221c000f4db2a38a8b63e22ff64f6ee7e (patch)
tree1e23e11ab8451341a381c76f9c853b7742d46741 /configure.ac
parent15a9e9a073a799341c18ace6b568e5317135056c (diff)
downloadcaja-a4822f6221c000f4db2a38a8b63e22ff64f6ee7e.tar.bz2
caja-a4822f6221c000f4db2a38a8b63e22ff64f6ee7e.tar.xz
GTK2: Use emanuele-f 's patch for build failure, fix build w/o libunique
Apply https://github.com/mate-desktop/caja/pull/658/commits/4b36a91af42d8efe0f594a95d28ab8448fd73b31 then fix the selectors in source files to use the boolean selectors for libunique
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index bf46174a..908483b3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -240,10 +240,12 @@ AC_ARG_ENABLE(libunique,
msg_libunique=no
if test "x$enable_libunique" != "xno"; then
msg_libunique=yes
- AM_CONDITIONAL([ENABLE_LIBUNIQUE], = "1")
+ AM_CONDITIONAL([ENABLE_LIBUNIQUE], true)
+ AC_DEFINE(ENABLE_LIBUNIQUE, 1, [define to enable libunique])
else
msg_libunique=no
- AM_CONDITIONAL([ENABLE_LIBUNIQUE], = "0")
+ AM_CONDITIONAL([ENABLE_LIBUNIQUE], false)
+ AC_DEFINE(ENABLE_LIBUNIQUE, 0, [define to disable libunique])
fi
dnl =====