summaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorWu Xiaotian <[email protected]>2019-07-01 11:00:12 +0800
committerraveit65 <[email protected]>2019-07-01 12:53:07 +0200
commit83fa9ede5c267fdd7ddca3f70801b838ee348190 (patch)
treee1411d07fd0069419320f5808bf076ab91ea4b72 /data/Makefile.am
parent61d19c0b626fef76a5d3df496bb292dcbca4bda4 (diff)
downloadcaja-83fa9ede5c267fdd7ddca3f70801b838ee348190.tar.bz2
caja-83fa9ede5c267fdd7ddca3f70801b838ee348190.tar.xz
create msgstr for data/browser.xml
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 92d6e824..09dc2509 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -2,7 +2,8 @@ NULL =
xml_in_files = caja.xml.in
xml_files = $(xml_in_files:.xml.in=.xml)
-$(xml_files): $(xml_in_files)
+
+%.xml: %.xml.in
$(AM_V_GEN) GETTEXTDATADIR=$(top_srcdir) $(MSGFMT) --xml --template $< -d $(top_srcdir)/po -o $@
desktopdir = $(datadir)/applications
@@ -30,13 +31,13 @@ org.mate.freedesktop.FileManager1.service: org.mate.freedesktop.FileManager1.ser
$(AM_V_GEN) sed -e "s|\@bindir\@|$(bindir)|" $< > $@
cajadatadir = $(datadir)/caja
-
+cajadata_in_files = browser.xml.in
cajadata_DATA = \
browser.xml \
caja-extras.placeholder \
caja-suggested.placeholder \
caja.css \
- caja-desktop.css \
+ caja-desktop.css \
$(NULL)
# app data file
@@ -52,6 +53,7 @@ EXTRA_DIST = $(cajadata_DATA) \
caja.css \
freedesktop-dbus-interfaces.xml \
$(xml_in_files) \
+ $(cajadata_in_files) \
$(desktop_in_files) \
$(service_in_files) \
$(appdata_in_files) \