summaryrefslogtreecommitdiff
path: root/libcaja-private/Makefile.am
diff options
context:
space:
mode:
authorinfirit <[email protected]>2015-09-06 16:46:20 +0200
committerinfirit <[email protected]>2015-09-06 16:46:20 +0200
commitcd39b1a25d204ed9fe7899a895bd75f71032ded5 (patch)
treed3361470cba96f79cd41eaff5eea0d052fce663e /libcaja-private/Makefile.am
parent3e9b28b2ebc9579bc868e2a8d1dc2d6f6b568c68 (diff)
downloadcaja-cd39b1a25d204ed9fe7899a895bd75f71032ded5.tar.bz2
caja-cd39b1a25d204ed9fe7899a895bd75f71032ded5.tar.xz
Rework gsettings schema building
* Bump intltool required version for gsettings support * Extract strings with intltool directly
Diffstat (limited to 'libcaja-private/Makefile.am')
-rw-r--r--libcaja-private/Makefile.am10
1 files changed, 3 insertions, 7 deletions
diff --git a/libcaja-private/Makefile.am b/libcaja-private/Makefile.am
index 4e7b10f9..947f9ef1 100644
--- a/libcaja-private/Makefile.am
+++ b/libcaja-private/Makefile.am
@@ -217,9 +217,7 @@ caja-marshal.list: $(libcaja_private_la_SOURCES) Makefile.am
$(AM_V_GEN)echo "#include \"caja-marshal.h\"" > $@ && \
$(GLIB_GENMARSHAL) --body --prefix=$(subst -,_,$*)_marshal $< >> $*-marshal.c
-gsettingsschema_in_files = org.mate.caja.gschema.xml.in org.mate.media-handling.gschema.xml.in
-gsettings_SCHEMAS = $(gsettingsschema_in_files:.xml.in=.xml)
-.PRECIOUS: $(gsettings_SCHEMAS)
+gsettings_SCHEMAS = org.mate.caja.gschema.xml org.mate.media-handling.gschema.xml
@INTLTOOL_XML_NOMERGE_RULE@
@@ -230,7 +228,7 @@ convert_DATA = caja.convert
EXTRA_DIST = \
caja-marshal.list \
- $(gsettingsschema_in_files) \
+ $(gsettings_SCHEMAS) \
$(convert_DATA) \
$(BEAGLE_SOURCES) \
$(TRACKER_SOURCES) \
@@ -238,9 +236,7 @@ EXTRA_DIST = \
CLEANFILES = \
$(BUILT_SOURCES) \
- $(schema_DATA) \
- $(gsettings_SCHEMAS) \
- caja-marshal.list \
+ caja-marshal.list \
$(NULL)
dist-hook: