summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrbuj <[email protected]>2019-09-25 16:35:09 +0200
committerraveit65 <[email protected]>2019-09-30 21:19:42 +0200
commit04657b8f6ef57fe5f6b620dbfe6db8b9a097ad9b (patch)
tree7504f2c94a6998634739e8d059176353186cfc12 /configure.ac
parentf25804efa335294b633759e19ae8d4964bd9614e (diff)
downloadengrampa-04657b8f6ef57fe5f6b620dbfe6db8b9a097ad9b.tar.bz2
engrampa-04657b8f6ef57fe5f6b620dbfe6db8b9a097ad9b.tar.xz
Use mate-compiler-flags.m4 provided by mate-common
USAGE: ./autogen.sh --enable-compile-warnings=no/minimum/yes/maximum/error@ If --enable-compile-warnings is not provided, the default is --enable-compile-warnings=yes
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 1 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index c2e6238..6600379 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11,6 +11,7 @@ AC_CONFIG_HEADER([config.h])
AC_CONFIG_MACRO_DIR([m4])
MATE_COMMON_INIT
+MATE_COMPILE_WARNINGS
AC_PROG_CC
AM_DISABLE_STATIC
@@ -48,26 +49,6 @@ AC_SUBST([GTK_LIBS])
dnl ===========================================================================
-WARN_CFLAGS="-Wall -Wcast-align -Wtype-limits -Wclobbered -Wempty-body -Wignored-qualifiers"
-
-for option in $WARN_CFLAGS; do
- SAVE_CFLAGS="$CFLAGS"
- CFLAGS="$CFLAGS $option"
- AC_MSG_CHECKING([whether gcc understands $option])
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[]])],[has_option=yes],[has_option=no])
- if test x$has_option = xyes; then
- WARNINGS="$WARNINGS $option"
- fi
- AC_MSG_RESULT($has_option)
- CFLAGS="$SAVE_CFLAGS"
- unset has_option
- unset SAVE_CFLAGS
-done
-unset option
-CFLAGS="$CFLAGS $WARNINGS"
-
-dnl ===========================================================================
-
AC_ARG_ENABLE(run_in_place,
AS_HELP_STRING([--enable-run-in-place],
[load ui data and extensions from the source tree]),,