summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrbuj <[email protected]>2019-10-01 13:11:03 +0200
committerraveit65 <[email protected]>2019-10-03 11:27:14 +0200
commit7d5048dcb46585fd4328ad1c2a4942aee02a22a0 (patch)
treeefe058b2ce2d06b47b111d0623f1dbbc30615126 /configure.ac
parentf10463c3de365ebdeb073892f79331c35de4c601 (diff)
downloadengrampa-7d5048dcb46585fd4328ad1c2a4942aee02a22a0.tar.bz2
engrampa-7d5048dcb46585fd4328ad1c2a4942aee02a22a0.tar.xz
Set compiler debug flags using MATE_DEBUG_CHECK and update configure summary
test: $ ./autogen.sh --enable-debug=profile --prefix=/usr <cut> Configuration: Source code location: . Compiler: gcc Compiler flags: -g -pg Warning flags: -Wall -Wmissing-prototypes Linker flags: -pg Caja support: yes PackageKit support: yes Run in place no Use libmagic: no JSON support: yes Now type `make' to compile engrampa $ ./autogen.sh --enable-debug --prefix=/usr <cut> Configuration: Source code location: . Compiler: gcc Compiler flags: -g -O0 Warning flags: -Wall -Wmissing-prototypes Linker flags: Caja support: yes PackageKit support: yes Run in place no Use libmagic: no JSON support: yes Now type `make' to compile engrampa $ grep MATE_ENABLE_DEBUG config.h
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c221bc4..23d5a02 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11,6 +11,7 @@ AC_CONFIG_HEADER([config.h])
AC_CONFIG_MACRO_DIR([m4])
MATE_COMMON_INIT
+MATE_DEBUG_CHECK([no])
MATE_COMPILE_WARNINGS
AC_PROG_CC
@@ -198,6 +199,9 @@ Configuration:
Source code location: ${srcdir}
Compiler: ${CC}
+ Compiler flags: ${CFLAGS}
+ Warning flags: ${WARN_CFLAGS}
+ Linker flags: ${LDFLAGS}
Caja support: ${enable_caja_actions}
PackageKit support: ${enable_packagekit}
Run in place ${enable_run_in_place}