summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorinfirit <[email protected]>2013-06-30 10:24:17 +0200
committerinfirit <[email protected]>2013-06-30 10:24:17 +0200
commitac5d3248257e9e1ddbf57ca5828a1de165d445a4 (patch)
tree1e2bf6455574395b84a2010595d05a13ff100b6b /configure.ac
parentc36eeddc49f116d5d860f2cd13eb94996489f70b (diff)
downloadengrampa-ac5d3248257e9e1ddbf57ca5828a1de165d445a4.tar.bz2
engrampa-ac5d3248257e9e1ddbf57ca5828a1de165d445a4.tar.xz
Add unachiver support
Based on the following commits from file-roller, https://git.gnome.org/browse/file-roller/commit/?id=2575177ac037d2a8d8f3056b10685928d80d6275 https://git.gnome.org/browse/file-roller/commit/?id=f26caa6d5b76d406976ea78630fbaae4c8126a2e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 85d5bbc..fd0bf47 100644
--- a/configure.ac
+++ b/configure.ac
@@ -29,6 +29,7 @@ dnl ==========================================================================
GLIB_REQUIRED=2.25.5
GIO_REQUIRED=2.25.5
CAJA_REQUIRED=1.1.0
+JSON_GLIB_REQUIRED=0.14.0
AC_MSG_CHECKING([which gtk+ version to compile against])
AC_ARG_WITH([gtk],
@@ -100,6 +101,23 @@ AC_SUBST(CAJA_CFLAGS)
AC_SUBST(CAJA_LIBS)
+PKG_CHECK_MODULES(JSON_GLIB,
+ [json-glib-1.0 >= $JSON_GLIB_REQUIRED
+ glib-2.0],
+ [enable_json_glib=yes],
+ [enable_json_glib=no])
+
+if test x$enable_json_glib = xyes ; then
+ AC_DEFINE(HAVE_JSON_GLIB, 1, [Define to 1 if json-glib support is included])
+fi
+
+AC_SUBST(JSON_GLIB_CFLAGS)
+AC_SUBST(JSON_GLIB_LIBS)
+
+AM_CONDITIONAL(ENABLE_JSON_GLIB, test x"$enable_json_glib" != x"no")
+
+dnl ******************************
+
dnl Checks for mkdtemp function
mkdtemp_missing=false
@@ -191,4 +209,5 @@ Configuration:
Caja support: ${build_caja_actions}
PackageKit support: ${enable_packagekit}
Run in place ${enable_run_in_place}
+ JSON support: ${enable_json_glib}
"