summaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorraveit <[email protected]>2012-11-05 17:14:51 +0100
committerraveit <[email protected]>2012-11-05 17:14:51 +0100
commite06e9b088a12dd098e11110f7d0d77ab8032e4eb (patch)
tree40a96b1b0e2ccd44771f5000e374e1920764ae59 /data/Makefile.am
parent8f8784ba4ebcd8eb099c4e119a9a8d5a349efd61 (diff)
downloadengrampa-e06e9b088a12dd098e11110f7d0d77ab8032e4eb.tar.bz2
engrampa-e06e9b088a12dd098e11110f7d0d77ab8032e4eb.tar.xz
Port to gsettings
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am63
1 files changed, 36 insertions, 27 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index de0a70b..41375d6 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -1,29 +1,31 @@
-@INTLTOOL_DESKTOP_RULE@
-
SUBDIRS = ui icons
+desktopdir = $(datadir)/applications
desktop_in_in_files = engrampa.desktop.in.in
desktop_in_files = $(desktop_in_in_files:.desktop.in.in=.desktop.in)
+desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
-desktopdir = $(datadir)/applications
-desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
+@INTLTOOL_DESKTOP_RULE@
matchdir = $(datadir)/engrampa
match_DATA = packages.match
-schemadir = @MATECONF_SCHEMA_FILE_DIR@
-schema_DATA = engrampa.schemas
+gsettingsschema_in_files = org.mate.engrampa.gschema.xml.in
+gsettings_SCHEMAS = $(gsettingsschema_in_files:.xml.in=.xml)
+.PRECIOUS: $(gsettings_SCHEMAS)
-gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+@INTLTOOL_XML_NOMERGE_RULE@
-install-data-local:
-if MATECONF_SCHEMAS_INSTALL
- MATECONF_CONFIG_SOURCE=$(MATECONF_SCHEMA_CONFIG_SOURCE) $(MATECONFTOOL) --makefile-install-rule $(srcdir)/$(schema_DATA)
-endif
+@GSETTINGS_RULES@
-install-data-hook: update-icon-cache
-uninstall-hook: update-icon-cache
-update-icon-cache:
+convertdir = $(datadir)/MateConf/gsettings
+convert_DATA = engrampa.convert
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+
+install-data-hook: update-cache
+uninstall-hook: update-cache
+update-cache:
if test -z "$(DESTDIR)"; then \
echo "Updating Gtk icon cache."; \
$(gtk_update_icon_cache); \
@@ -32,18 +34,25 @@ update-icon-cache:
echo "*** $(gtk_update_icon_cache)"; \
fi
-
-EXTRA_DIST = \
- $(desktop_in_in_files) \
- $(desktop_in_files) \
- $(desktop_DATA) \
- packages.match.in \
- packages.match \
- $(schema_DATA)
-
-
-DISTCLEANFILES = \
- $(desktop_in_files) \
- $(desktop_DATA)
+EXTRA_DIST = \
+ engrampa.convert \
+ packages.match.in \
+ packages.match \
+ $(desktop_in_in_files) \
+ $(desktop_in_files) \
+ $(desktop_DATA) \
+ $(gsettingsschema_in_files) \
+ $(NULL)
+
+DISTCLEANFILES = \
+ $(desktop_in_files) \
+ $(desktop_DATA) \
+ $(NULL)
+
+CLEANFILES = \
+ $(gsettings_SCHEMAS) \
+ $(NULL)
+
+dist-hook: cd $(distdir); rm -f $(CLEANFILES)
-include $(top_srcdir)/git.mk