summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorrbuj <[email protected]>2019-09-25 16:35:09 +0200
committerraveit65 <[email protected]>2019-09-30 21:19:42 +0200
commit04657b8f6ef57fe5f6b620dbfe6db8b9a097ad9b (patch)
tree7504f2c94a6998634739e8d059176353186cfc12 /src/Makefile.am
parentf25804efa335294b633759e19ae8d4964bd9614e (diff)
downloadengrampa-04657b8f6ef57fe5f6b620dbfe6db8b9a097ad9b.tar.bz2
engrampa-04657b8f6ef57fe5f6b620dbfe6db8b9a097ad9b.tar.xz
Use mate-compiler-flags.m4 provided by mate-common
USAGE: ./autogen.sh --enable-compile-warnings=no/minimum/yes/maximum/error@ If --enable-compile-warnings is not provided, the default is --enable-compile-warnings=yes
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ff381fe..f0cd3e7 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,3 +1,5 @@
+NULL =
+
SUBDIRS = commands sh ui
bin_PROGRAMS = engrampa
@@ -36,7 +38,9 @@ AM_CPPFLAGS = \
-DPRIVEXECDIR=\"$(privexecdir)\" \
-DSHDIR=\"$(shdir)\" \
$(FR_CFLAGS) \
- $(JSON_GLIB_CFLAGS)
+ $(JSON_GLIB_CFLAGS) \
+ $(WARN_CFLAGS) \
+ $(NULL)
BUILT_SOURCES = \
fr-marshal.c \