summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorinfirit <[email protected]>2014-11-20 14:27:41 +0100
committerinfirit <[email protected]>2014-11-20 19:44:58 +0100
commit2e085a0a0542f9e5d6b2daf001143f8b9503490a (patch)
tree351d2c1a437deb67fb3284e4762f3c926bdf2060 /src/Makefile.am
parent0ecd00c6f86b4558e978c07221baebe64039525b (diff)
downloadengrampa-2e085a0a0542f9e5d6b2daf001143f8b9503490a.tar.bz2
engrampa-2e085a0a0542f9e5d6b2daf001143f8b9503490a.tar.xz
add support for magic based identification of files
Based on FR commits: 7b23961d200e3545af3815a8eb40d6d31757024f f08945a652ae1365ad6bbc5e3dcc8709031b5faf b6104a74e66ceca98884a6f974485a96a83526a2 From: Saleem Abdulrasool <[email protected]>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index cba14ad..ef11ec3 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -189,7 +189,11 @@ fr-enum-types.c: typedefs.h fr-enum-types.h
engrampa_LDADD = \
$(top_builddir)/copy-n-paste/libeggsmclient.la \
$(FR_LIBS) \
- ${JSON_GLIB_LIBS}
+ ${JSON_GLIB_LIBS}
+
+if ENABLE_MAGIC
+engrampa_LDADD += $(MAGIC_LIBS)
+endif
EXTRA_DIST = fr-marshal.list