summaryrefslogtreecommitdiff
path: root/data/icons/22x22/apps/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/icons/22x22/apps/Makefile.am')
-rw-r--r--data/icons/22x22/apps/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/data/icons/22x22/apps/Makefile.am b/data/icons/22x22/apps/Makefile.am
new file mode 100644
index 0000000..5387a25
--- /dev/null
+++ b/data/icons/22x22/apps/Makefile.am
@@ -0,0 +1,26 @@
+themedir = $(datadir)/icons/hicolor
+size = 22x22
+context = apps
+
+iconsdir = $(themedir)/$(size)/$(context)
+
+icons_DATA = \
+ file-roller.png
+
+noinst_DATA =
+
+EXTRA_DIST = \
+ $(icons_DATA) \
+ $(noinst_DATA)
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+
+install-data-hook:
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi
+-include $(top_srcdir)/git.mk