summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorManatsawin Hanmongkolchai <[email protected]>2022-11-14 23:00:54 +0700
committerraveit65 <[email protected]>2023-04-20 18:07:49 +0200
commitfaf2001f46509a7434fc10ee848ce1ce84255dcd (patch)
tree5987f3ddabfe7909fb2bd2fd5d038e6358220798 /meson.build
parent06de02ac5acb699156401bcf48009a670f98033e (diff)
downloadeom-faf2001f46509a7434fc10ee848ce1ce84255dcd.tar.bz2
eom-faf2001f46509a7434fc10ee848ce1ce84255dcd.tar.xz
Add enum and thumbnailer build
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 7 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 0ec3e50..237ea0e 100644
--- a/meson.build
+++ b/meson.build
@@ -131,7 +131,7 @@ endif
if get_option('thumbnailer')
if get_option('gdk-pixbuf-thumbnailer')
- eom_thumbnailer = find_program('gdk-pixbuf-thumbnailer')
+ eom_thumbnailer = find_program('gdk-pixbuf-thumbnailer').full_path()
else
magick = dependency('MagickWand', version : '>= 6.2.6')
if magick.version().version_compare('>= 7')
@@ -139,11 +139,12 @@ if get_option('thumbnailer')
else
conf.set('HAVE_IMAGEMAGICK6', 1)
endif
- #all_deps += [magick]
eom_thumbnailer = 'eom-thumbnailer'
endif
endif
+pkg_info.set('EOM_THUMBNAILER', eom_thumbnailer)
+
# XMP support
if xmp.found()
conf.set('HAVE_EXEMPI', 1)
@@ -204,4 +205,8 @@ subdir('help')
subdir('data')
subdir('doc')
+if get_option('thumbnailer')
+ subdir('thumbnailer')
+endif
+
# TODO: Changelog