summaryrefslogtreecommitdiff
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
authorrbuj <[email protected]>2021-01-25 19:46:32 +0100
committerraveit65 <[email protected]>2021-02-05 21:36:53 +0100
commit8a653210e2ecf00c11bd8cdf44af2d8c4814fadf (patch)
tree78693278cad2311662a583f6a0b6565ec395a292 /plugins/Makefile.am
parentafd8f48f9b71f68953bc8e6bf4859031475aee0f (diff)
downloadeom-8a653210e2ecf00c11bd8cdf44af2d8c4814fadf.tar.bz2
eom-8a653210e2ecf00c11bd8cdf44af2d8c4814fadf.tar.xz
build: allow users to disable gettext support (--disable-nls)
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index 8e11b07..48cb92f 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -50,7 +50,11 @@ plugins_in_in_files = $(plugins_in_files:.desktop.in=.desktop.in.in)
plugins_DATA = $(plugins_in_files:.plugin.desktop.in=.plugin)
%.plugin: %.plugin.desktop.in
+if USE_NLS
$(AM_V_GEN) $(MSGFMT) --desktop --keyword=Name --keyword=Description --template $< -d $(top_srcdir)/po -o $@
+else
+ $(AM_V_GEN) cp $< $@
+endif
DISTCLEANFILES = $(plugins_in_files)
CLEANFILES = $(plugins_DATA)