summaryrefslogtreecommitdiff
path: root/cut-n-paste/toolbar-editor/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'cut-n-paste/toolbar-editor/meson.build')
-rw-r--r--cut-n-paste/toolbar-editor/meson.build27
1 files changed, 27 insertions, 0 deletions
diff --git a/cut-n-paste/toolbar-editor/meson.build b/cut-n-paste/toolbar-editor/meson.build
new file mode 100644
index 0000000..3295507
--- /dev/null
+++ b/cut-n-paste/toolbar-editor/meson.build
@@ -0,0 +1,27 @@
+eggheaders = [
+ 'egg-editable-toolbar.h',
+ 'egg-toolbars-model.h',
+ 'egg-toolbar-editor.h',
+]
+
+eggmarshalers = gnome.genmarshal('eggmarshalers', sources: ['eggmarshalers.list'], prefix: '_egg_marshal')
+eggtypebuiltins = gnome.mkenums_simple('eggtypebuiltins', sources: eggheaders)
+
+src = [
+ eggmarshalers,
+ eggtypebuiltins,
+ 'egg-editable-toolbar.c',
+ 'egg-toolbars-model.c',
+ 'egg-toolbar-editor.c',
+ eggheaders,
+]
+
+toolbareditor = static_library(
+ 'toolbareditor',
+ src,
+ dependencies: all_deps,
+ include_directories: top_inc,
+ c_args: ['-DCURSOR_DIR="' + pkgdatadir + '"'],
+)
+
+toolbareditor_inc = include_directories('.')